Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got a HP MediaSmart Windows Home Server EX490 and I'd like to run my own Minecraft server.

I have the server software downloaded on my WHS box, so through a Remote Desktop connecting I startup the software which runs fine.

However the moment a Minecraft client trys to connect to the server, my Remote Desktop connection freezes and the whole WHS appears to be frozen.

I've tried this a number of the times and get the same result each time. Is there a reason why WHS would do this? Has anyone else had the same issue?

Server log

2011-02-27 19:23:58 [INFO] Starting minecraft server version Beta 1.3  
2011-02-27 19:23:58 [INFO] Loading properties  
2011-02-27 19:23:58 [INFO] Starting Minecraft server on *:25565  
2011-02-27 19:23:58 [WARNING] The server will make no attempt to authenticate usernames. Beware.  
2011-02-27 19:23:58 [WARNING] While this makes the game possible to play without internet access, it also opens up the ability for hackers to connect with any username they choose.  
2011-02-27 19:23:58 [WARNING] To change this, set "online-mode" to "true" in the server.settings file.  
2011-02-27 19:23:58 [INFO] Preparing level "world"  
2011-02-27 19:23:58 [INFO] Preparing start region  
2011-02-27 19:24:00 [INFO] Preparing spawn area: 93%  
2011-02-27 19:24:00 [INFO] Done (1281633001ns)! For help, type "help" or "?"  
2011-02-27 19:28:20 [INFO] MaverickUK [/] logged in with entity id 1  
2011-02-27 19:28:24 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?  
2011-02-27 19:28:28 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?  
2011-02-27 19:28:30 [WARNING] Can't keep up! Did the system time change, or is the server overloaded?  
2011-02-27 19:29:18 [INFO] MaverickUK lost connection: disconnect.overflow  

Other people having related issues

share|improve this question
this may be unrelated, but's auth has been having some serious problems. I can only connect to my server if I put 'online-mode=false' in to bypass the auth entirely. – Cory J Feb 8 '11 at 0:12
Do you still have this problem? – badp Feb 14 '11 at 4:20
@cory-j Just given the 'online-mode=false' a go, but the problem is still there :( @badp Yup, still have the problem. Been hosting the server on a spare computer at my parent's house, if you can believe it! – Peter Bridger Feb 27 '11 at 19:30
From the log, your server is overloaded just serving one player connection. What are the specs on this machine? – SevenSidedDie Jun 23 '11 at 1:22

I haven't touched it recently, but I was running Minecraft fine on my WHS (an HP LX190) without any real problems. I followed these directions to run it as a service so I didn't have to leave an RDP session going:

Install Summary - Download yajsw and extract to any folder. - Open task manager and find the "java" pid under processes. This is most likely your minecraft server. - Open a command prompt and browse to the "bat" folder under yajsw. (ex. D:\yajsw-beta-10.3\bat). - Run genConfig.bat (ex. genConfig.bat 2467).

wrapper.conf - Browse to "conf" folder (ex. D:\yajsw-beta-10.3\conf) and open wrapper.conf in a text editor. - Set the working directory to your minecraft .jar server file. (ex. \minecraftserver\ for D:\minecraftserver). - Uncomment and enter your admin account password. Make sure the username on the line above is correct. - Fill in service name and descriptions.

Create/Install Service - Run installService.bat from the bat directory. (ex. D:\yajsw-beta-10.3\bat) - Open Services Manager through administration tools. - Right click the server, properties. - Browse to "Log On" tab. - Change to "This Account" and use the same account in your wrapper.conf.

Start the service.

Minecraft runs on port 25565, so it shouldn't be conflicting with RDP anyway (which is 3389), but this makes things much easier for me anyway.

share|improve this answer

Check to see if Minecraft is running on the same port as remote desktop. This could cause a port conflict that might freeze your system.

share|improve this answer
RDP is 3389 and Minecraft is 25565 – Peter Bridger Feb 27 '11 at 19:21

protected by fredley Dec 16 '13 at 16:10

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.