Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm trying to play an old school DOS Game I got using the DOSBOX DOS emulator, but the problem I have is that the mouse jumps all over the screen and does not allow me to have a good control. The game is Cannon Fodder, which need to have mouse input. So I'm thinking it is problem of conversion from USB mouse to the serial driver which the emulator uses. I already tried to lower the sensitivity using the emulator and to lower it using windows settings.

Anyone have any suggestions on how to resolve this?

share|improve this question
    
+1 for the most bestest game of all times. –  DrFish Feb 14 '11 at 15:36
    
DId a little research on this. Have you tried a PS/2 mouse, or can you do that? –  DrFish Feb 14 '11 at 16:06
    
only have usb input –  Vladimir Oselsky Feb 14 '11 at 18:48
add comment

3 Answers

up vote 3 down vote accepted

Not 100% sure this is the problem, but autolock often causes mouse issues in DOSBox. So try setting it to the opposite of whatever it currently is:

  • In your dosbox.conf file, look for a line setting autolock=false and remove the line (or change the false to true).
  • Or, if no line with autolock exists, add one with autolock=false.
share|improve this answer
1  
i was able to fix it looks like game created it own config file called. dosboxCannonFodder.conf so i had to modify that file. i set sensitivity=1 –  Vladimir Oselsky Feb 14 '11 at 19:10
add comment

If you are trying to run dosbox in a virtualbox Ubuntu host, I had the same issue and it was driving me crazy. The mouse would just get stuck in a corner and wouldn't move except to the other corners. Here's the solution I found:

Make a text file and put this in it:

#!/bin/bash
export SDL_VIDEO_X11_DGAMOUSE=0
dosbox

Save it on your desktop or somewhere else, right click on it and put a check where it say "allow to execute as application". Run the file and the mouse issue will be fixed.

share|improve this answer
add comment

I know that the original poster has already resolved their issue, but for everyone else hitting this from Google: for me this was an issue with VirtualBox's mouse integration. To fix it, disable your virtual machine's mouse integration by right clicking on the mouse icon in the bottom right-hand corner (second icon from the right).

After this, the mouse should respond to the sensitivity setting in DOSBox.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.