Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I just started playing Dwarf Fortress, and after half an hour, the laptop shut down. The Dwarf Fortress process seems to be at 100% processor usage whenever it isn't paused. Is there a setting for limiting this?

share|improve this question
5  
Honestly, this is not a gaming question, this is a question about using your computer. Now I realize the people over at SuperUser have some allergy to the mentioning of any video game, but fortunately for you: they already answered this one –  tzenes Feb 19 '11 at 22:35
    
@tzenes: I had hoped for a Dwarf Fortress-specific setting, since (I believe) it takes as much processing power as it can, no matter how much is available. –  user7220 Feb 19 '11 at 22:57
    
I realize you don't understand how DF works, but the design of DF is just the opposite: its designed to eat as much CPU as possible. Regardless, this is a general computer question: how do I limit a program's processor usage? –  tzenes Feb 19 '11 at 23:04
    
I've given an answer specific to DF which might work, there are ways to limit the speed and in theory the required CPU, so it is answerable as a Gaming specific question (for this game at least). –  Kevin van der Velden Feb 19 '11 at 23:28
add comment

3 Answers 3

up vote 4 down vote accepted

You can, in theory, limit the game update speed and/or graphic update speed, DF will try to run as many updates as possible with respect to the limit, your CPU is stuck at 100% because it's not fast enough (don't worry, as far as I know there are no CPUs fast enough to run DF at the default speed without using all the CPU).

Although settings this at even, say 1, might not work (depends on how the limit is implemented, it should say to the OS "I don't need to do anything for X milliseconds" but it's probably a low priority bug) it's worth a try.

share|improve this answer
add comment

If you have a dual core processer (or higher) you could try opening task manager, clicking the processes tab, locate the process for the game, right click and then select 'Set Affinity'. Once the new tab is open you can choose how many cores that process will use at any one time - limiting it to 1 might help with your problem as part of the processor will no longer be in use.

share|improve this answer
add comment

In the directory where you installed Dwarf Fortress, there will be a subdirectory "data", in which there will be a subdirectory "init", in which there will be a file "init.txt". That file has two settings that can affect the processor usage of Dwarf Fortress.

FPS_CAP is the maximum number of updates per second; higher values will increase processor usage and lower values will decrease it.

PRIORITY is the process scheduling priority. It has six values; from highest processor usage to lowest they are REALTIME (not recommended for single core machines), HIGH, ABOVE_NORMAL, NORMAL, BELOW_NORMAL and IDLE.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.