Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have pretty decent hardware and I run many games on it. But Civ 5 is unacceptably slow when it reaches an advanced stage where it shows the whole map and there are many units.

I tried to monitor the CPU and memory and I couldn't find the bottleneck. I run it in a fast SSD and I didn't monitor my GPU.

I noticed a speed improvement when I changed from DX10/11 to DX9. But the performance isn't acceptable yet.

share|improve this question
2  
Try to play when the view is a bit more zoomed in, perhaps? I've noticed a significant drop in performance the more you zoom out. –  Oak Feb 22 '11 at 0:33
3  
When you say it is slow, do you mean that the graphics and scrolling are slow, or do you mean that it takes a long time for the computer players to take their turns? –  bwarner Feb 22 '11 at 13:03
    
@bwarner both. sometimes just the npc turns that bother me –  Jader Dias Feb 24 '11 at 2:15
add comment

9 Answers

up vote 15 down vote accepted

Get FRAPS or some other tool to display the frame rate and monitor the effects of your changes.

There are a quite some things you could try to do:

  • reduce the graphics settings
  • play at a lower resolution
  • use the strategic view (doesn't help as much as one would think)
  • play on smaller maps
  • don't zoom out as much (as Oak already said)
  • win before the modern age
  • install the latest graphics drivers

If you're talking about the time between turns, you'll be happy to know that the next patch is supposed to significantly reduce that time.

You did not write your exact specifications of your computer, Civilization V is a pretty resource-hungry game, you'll need a relatively new and powerful CPU and GPU to play it at decent settings.

share|improve this answer
5  
Win before the modern age =) It sounds easier than it is –  Jader Dias Feb 22 '11 at 11:48
1  
@Jader I know, but it is actually one of the best ways to ensure good performance. The difference between early game and late game is pretty big. –  Mad Scientist Feb 22 '11 at 13:00
    
Had a Radeon 4850 card. It plays fast but I can't stand the heat and fan noise. Switching to strategic view made a lot of difference in reducing GPU load. –  Augustus Thoo Jul 27 '12 at 16:16
add comment

From the official forum:

The game is REALLY laggy/slow/has graphical issues.

This is most likely a video driver problem. If you are uncomfortable DLing the most recent BETA drivers for your card (if you have Nvidia), then just make sure you have the most recent driver and as long as you do, do a CLEAN reinstall of it and then reinstall DirectX11.

If you are ok with DLing the Beta, go to the Nvidia website and go to "Archived and Beta drivers", select your card, and select the most recent from that list. Download it, and select the "Custom Install" option and select "Clean install." If that alone does not help, reinstall DirectX11 and hopefull it will be smooth sailing.

share|improve this answer
add comment

CTRL + G: I find removing the grid lines improves the game speed dramatically in the late game.
CTRL + R: Removing resource icons.

share|improve this answer
add comment

I was having some horrible slowdowns on two different machines during later eras. For me the solution was to to add both the save directory (My Documents\My Games\Sid Meier's Civilization 5) and the game directory (Program Files (x86)\Sid Meier's Civilization V) to AVG Resident Shield's exclusion list.

The game still has some memory leakage that slows it a little over time but i'm no longer getting the 1.5-2 minutes per turn i was getting (now the max is like 30 seconds).

share|improve this answer
add comment

Civilization V can be a very demanding game when it comes to your computer. one way you could improve the speed is by closing out of other programs and also turn down some of the graphical settings. Also the map size and the amount of leaders you are playing with can also effect your preformance.

share|improve this answer
add comment

I found there were two video options that made a massive difference to the game's playability for me:

Terrain Shadow Quality set to Off in video options completely got rid of the lag for me in the map.

Leader Scene Quality set to Low stopped the diplomacy screens from loading slowly

I assume that different setups will have different optimizations, but given that you have to restart the game every time for every video change I'd recommend trying them first. I was able to play at a high resolution with 20-30 fps, which doesn't make the map feel jerky when scrolling around.

To find these I installed FRAPs to watch the FPS and started by turning everything down to the lowest setting and gradually re-enabling everything. Nothing had a noticeable lag effect apart from the Terrain Shadow Quality in the map.

share|improve this answer
add comment

Quick Combat and Quick moves make a difference in the late game. Evidently, AI moves/fights at the animated on-screen unit speed, even in areas that are fog-covered or have not been revealed.

Switching this option reduced my turn wait-time by half.

Worth a shot for anyone.

share|improve this answer
1  
If your performance issue is "it takes forever for other civs to take their turn" then this is a huge improvement. I just went from 30-45 second turns to 5 second turns. –  Caspar Dec 28 '13 at 23:08
add comment

The strange thing is... Everybody says that Civ5 is demands many of your computer. But Civ5 does not completely uses your system. This is mostly normal, because many new games like: Battlefield 3 & Farcry 3 demands between 80%&100% of your graphics card.

I monitort my system in Civ5:

GPU's between 30/40 % (sli) CPU @ 18%Max Memory @ 19% Max...

and no.. the cpu usage doesnt increase if i press end-turn. Why does civ5 asks so few from my system?

Ok OT: Few tips that helped me...

1.Disable Barbarians 2.Start a game without City-states and @ to compensate 2 extra civilizations.

share|improve this answer
    
You can add a line break by putting two spaces at the end of the line see linebreaks in the editing help –  Alex Mar 18 '13 at 11:47
add comment

Well seem I find a fix to the problem, just download the lastest version including all new DLC and Expantion and work flawless on a Phenom II 955 +HD4890, no delay on turns what so ever even on large maps at the very end stages of the game, also there is improve in the gpu performance.

share|improve this answer
add comment

protected by Community Dec 29 '13 at 2:32

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.