Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I cannot get my w key to work in Starcraft 2. I can assign a hotkey to it in settings, and it works in the chat, so it obviously "works", but it never works for unit command hotkeys.

I have a bizarre setup I realize, but I cannot really live without it:

  • I use Dvorak-International keyboard layout, because I use Dvorak, I use an American keyboard, and I frequently need to type international characters.
  • I use grid for lefties in Starcraft 2

For some reason, the w key does not register at all during gameplay. This is the c for the normal grid layout. Bottom row, 3rd column of the grid.

This makes it impossible to use a hotkey for:

  • Hallucination
  • Transfusion
  • Raven seeker missile

And others.

Anyone have a suggestion for a solution?

Update

I figured out that it is indeed the layout, and a bug in Starcraft 2. It seems that while Starcraft 2 handles alternate keyboards surprisingly well, it falls short. I found that Starcraft will consider it a duplicate when a dvorak key and its corresponding qwerty key are assigned. That's confusing...

For example, I assign / using my dvorak keyboard (that's the [ key to you qwerty folks). Now I mysteriously cannot assign z (that's / in qwerty). There is no logical reason these should be considered duplicates; they are two physically different keys, so it seems that Starcraft 2 still uses the qwerty layout for some of its checking.

Man I can't think of a better way to explain it; that must be confusing.

Anyway I did as I said and totally revamped my keyboard layout anyway. I have to just live with a few "dead" keys.

Anyone know where I can file a bug report to Blizzard?

share|improve this question
    
In regards to your latest edit, your question has been answered here. 'gratz on finding the problem! –  Mana Feb 24 '11 at 12:00
add comment

2 Answers

up vote 2 down vote accepted

I'm guessing its most likely because of your keyboard layout. I would set up an alternate layout and a Windows hot key to switch to it for Starcraft 2.

I use U.S. International myself but I always make sure that I have a way to switch to U.S. Standard since I occasionally run into games which have issues with it.

share|improve this answer
    
Probably. Honestly I don't like the lefty grid that much though and I may create my own anyway which just avoids the issue altogether. –  tenfour Feb 23 '11 at 15:21
add comment

I believe that you can do this via "keyboard setup" in-game menu.
In last tab of settings there are some misc buttons like 'voice chat'.. 'warpgates' hotkey is also here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.