Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm playing Fallout: New Vegas on a decent machine. The game normally runs with 70-90 FPS on highest settings when not using vsync. But I hate playing without vsync because the video tearing is unbearable, so I enabled it. Afterwards, the FPS stabilized at 60, but the game stutters. This is especially noticeable when moving sideways. The only solution I found so far is setting the following option in fallout.ini:

iFPSClamp=60

With this setting the game is absolutely smooth as long as the FPS does not drop below 60. But as soon as it drops to a FPS like 50 the game runs in slow motion, which is also not acceptable. Another problem is that this also happens on the lowest video settings. Some regions in the game are producing significant FPS drops which seem to be unrelated to the video settings.

So these are my current options:

  • Enable vsync and iFPSClamp: No screen-tearing and smooth game play but slow-motion in some areas.
  • Enable vsync without iFPSClamp: No screen-tearing but game stutters even when FPS is high.
  • Disable vsync and enable iFPSClamp: Screen-Tearing and game play is too fast (When FPS is the double of the iFPSClamp value then game play is twice as fast).
  • Disable vsync and disable iFPSClamp: Screen-Tearing.

So with these two settings, no option is acceptable. Are there more known configuration settings I could try out to get a smooth and fast game play?

My system: Asus P7P55D Pro, Intel Core i7 2.8 GHz, 4 GB RAM, NVidia 285 GTX, Windows 7 64 bit.

I had the same problems with Fallout 3 on an older machine: Some Intel board (Can't remember the model), Quadcore CPU with 2.4 GHz, NVidia 8800 GTX, Windows XP 32 bit.

share|improve this question
    
Might be an idea to include a system spec, might be something to do with your hardware –  Craig Pilgrim Feb 26 '11 at 15:48
    
I don't know about Fallout, but I use a similar technique in the Unreal Tournament DX9 renderer. There, I had to set fps cap to 62, to have a game with almost no tearing. You might play with the numbers around 60. Some renderers work best with a bit less than your vertical refresh rate, some with a bit more. This of course, is when vsync is off. –  Bora Mar 3 '11 at 10:12
    
I added my system specs. –  kayahr Mar 22 '11 at 7:19
add comment

3 Answers

Try updating your vga driver, try disabling shadows, and try the Enhanced Shaders by Tapio Schnaars.

share|improve this answer
    
The Enhanced Shaders page claims they actually reduce FPS... –  badp Mar 13 '11 at 18:50
    
i don't know why but in my pc, the enhanced shaders actually makes the game faster, maybe it's something related to DX9? somewhere in the comments page, i read that some graphic card is more compatible with DX9 than the DX10 –  user7765 Mar 14 '11 at 0:39
    
I have this problem since Fallout 3 and I'm updating my Video driver regularly in the naive hope that it solves the problem. No luck so far. –  kayahr Mar 22 '11 at 7:20
add comment

The problem isn't video-related; it's your hard drive subsystem. Your computer is bogging down (like mine) when it's loading new terrain as you walk. In a "sandbox" game like this, the computer is always downloading new "mini" maps as you move over the landscape. (Look at the "local" map on your PipBoy while outside, you'll see that it's a small fraction of what you can see. As you cross the borders of these small maps, the game has to load the new map from the drive.) I have 2 10K Raptors (from many years ago), STRIPED, and I still get very noticeable lag when this happens. I would really like to upgrade to an SSD(s). The latest figures I've seen show that a single, mainstream SSD would be 30 TIMES FASTER than my stripe set. :-(

share|improve this answer
    
This is a good suggestion. I had a very similar issue playing MW2 off of an external hard drive. –  Mechko Mar 21 '11 at 18:00
    
That's not what I mean. Short stuttering while moving from one area to another is normal when the game needs to load new scenery or textures. This is totally acceptable. My stuttering is permanent in some areas and I only have the strafe a little right and left for it. No new scenery or textures are loaded for this, the hard drive LED is always off. –  kayahr Mar 22 '11 at 7:12
add comment

i was having stuttering problems even with high fps, at high settings. i disabled one of the dual monitors, and it's much better now!

there's still some stuttering, but it's due to loading new stuff in the map, when i'm in a place that's already been fully loaded, stutter is no more :)

share|improve this answer
1  
I only have one monitor so this isn't my problem. –  kayahr Jun 4 '11 at 6:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.