Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I just downloaded the Crysis 2 demo via Steam. It launches ok, showed an intro movie, and lists a bunch of servers to join. However, every time I join a game it does the 60 second count down and gets stuck on the last second. The chat goes 'silent' so I figure maybe other folks are playing the game successfully, leaving me to guard the lobby :)

Anyone else getting this? Any ideas?

Edit Looks like this guy is having the same issue, though no answer over there.

share|improve this question
2  
For starters I would verify the game files integrity, it worked for me when encountering a weird issue :) –  Oak Mar 2 '11 at 21:35
    
Aw, i was going to say the same... =) –  Lysarion Mar 3 '11 at 9:54
    
@Oak, @Lysarion, cheers -- just tried that. It didn't say anything was amiss, but I'll give it a shot and see. Have also rebooted. –  Drew Noakes Mar 3 '11 at 15:34
    
Win to verification of game cache again \o/ –  Lysarion Mar 3 '11 at 15:59

1 Answer 1

up vote 2 down vote accepted

Some combination of rebooting and verifying the integrity of the game cache via Steam sorted it out.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.