Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

after playing Half Life 1 online for a while and then restarting, this is what my menu looks like:

enter image description here

All the elements load an online server, instead of doing what they are supposed to (for example, Find Servers is supposed to open a window where you can choose servers).

Is this a bug? How to get it back to normal?

share|improve this question
add comment

3 Answers

Replace your text in the gamemenu.res file with following text:

"game menu" { "1" { "label" "#GameUI_GameMenu_ResumeGame" "command" "ResumeGame" "OnlyInGame" "1" } "2" { "label" "#GameUI_GameMenu_Disconnect" "command" "Disconnect" "OnlyInGame" "1" "notsingle" "1" } "3" { "label" "#GameUI_GameMenu_PlayerList" "command" "OpenPlayerListDialog" "OnlyInGame" "1" "notsingle" "1" } "4" { "label" "" "command" "" "OnlyInGame" "1" } "5" { "label" "#GameUI_GameMenu_NewGame" "command" "OpenNewGameDialog" "notmulti" "1" } "6" { "label" "#GameUI_GameMenu_LoadGame" "command" "OpenLoadGameDialog" "notmulti" "1" } "7" { "label" "#GameUI_GameMenu_SaveGame" "command" "OpenSaveGameDialog" "notmulti" "1" "OnlyInGame" "1" } "8" { "label" "" "command" "" "notmulti" "1" } "9" { "label" "#GameUI_GameMenu_FindServers" "command" "OpenServerBrowser" "notsingle" "1" } "10" { "label" "#GameUI_GameMenu_CreateServer" "command" "OpenCreateMultiplayerGameDialog" "notsingle" "1" } //"11" //{ //"name" "LoadDemo" //"label" "#GameUI_GameMenu_PlayDemo" //"command" "OpenLoadDemoDialog" //} "12" { "label" "" "command" "" "notsingle" "1" } "13" { "label" "#GameUI_GameMenu_ChangeGame" "command" "OpenChangeGameDialog" "notsteam" "1" "notsingle" "1" "notmulti" "1" } "14" { "label" "#GameUI_GameMenu_Options" "command" "OpenOptionsDialog" } "15" { "label" "#GameUI_GameMenu_Quit" "command" "Quit" } }

share|improve this answer
add comment
up vote 2 down vote accepted

It looks like I fixed it.

The problem seems to have been the file Half-Life\valve\resource\GameMenu.res which got overwritten (probably a bug) in some way.

Reinstalling the default GameMenu.res fixed the problem.

share|improve this answer
    
Please use the checkmark located underneath the vote total on this answer to mark it as accepted. :) There's a 2 day grace period required before being able to do this for answering your own questions, but after that time has passed, you're able to mark it. –  FAE Mar 11 '11 at 17:44
add comment

While I'm not sure how to get it back to normal, as an alternative, you can use the Steam Server Browser (If Steam is running, single-click its icon, then click Servers) to find games, just make sure you set the filter to Deathmatch Classic.

Steam Server Browser should Deathmatch Classic games

share|improve this answer
    
That is, assuming you're referring to Half-Life Deathmatch. –  user2974 Mar 5 '11 at 2:14
    
It's just the classic Half-Life 1, without Steam. –  user7556 Mar 5 '11 at 2:17
1  
@meh: Then can I suggest updating HL1? The newer versions of HL1 do use Steam. –  user2974 Mar 5 '11 at 6:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.