Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My friend and I are trying to play Warhammer 40k Retribution together in campaign coop. When one of us accepts the others' Steam invite, the connecting player sees "Connecting..." then "Connection timed out". The other player sees no indication that anyone is connecting.

We're on a lan, both connected to the same router. Both of us have version the latest version currently (3.12.05944), both of us have all firewalls disabled on our machine (though we're behind a NAT). The NAT does support uPNP.

Any help is greatly appreciated.

share|improve this question
Kinda solved itself for me, I bought an SSD and reinstalled Win7 and Retribution onto it and suddenly it worked. I wish I had better information for anyone else with this problem though. – Peter Burns Mar 16 '11 at 1:26
you should really add that as a question, then mark it as the answer. That way, if other people find this question, they'll know it worked for you... – Dylan Corriveau Nov 6 '14 at 17:07
I'm not sure I understand your point about adding something as a question. The reason I haven't added an answer is that "buy a new hard drive and reinstall windows" isn't super helpful. – Peter Burns Nov 7 '14 at 2:40

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.