Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm sure Arda mentioned this in chat, and it was mentioned in the site too, but for the life of me I wasted 15 minutes trying to get back into TF2 after alt-tabbing out, then wasted 15 minutes trying to find the relevant piece of information again.

So I'll ask: how do you turn "fake fullscreen" (windowed mode maximized without border) in TF2, L4D, HL2 and the other Source games?

share|improve this question
    
There is, by the way, an easy way to do this with any game, not just Source games. –  user56 Mar 10 '11 at 13:26
1  
@ArdaXi Maybe you could've linked to the relevant question while you were at it. –  badp Mar 10 '11 at 14:17
    
That's not the relevant question. I don't think my solution has ever been asked, since it's much more useful if you have multiple screens. That's not to say you couldn't have linked to that in your question yourself. –  user56 Mar 10 '11 at 14:57
    
@Arda If I could've found your solution I wouldn't have asked this. I know it should be in the starred list, except I couldn't find it. –  badp Mar 10 '11 at 15:01
1  
@Lohoris Then edit it in the question! –  badp Nov 26 '11 at 18:16

1 Answer 1

up vote 9 down vote accepted

Use the following as your command line: (From the library right click on the game, then pick Properties → Set Launch Options.)

-sw -noborder

-sw means "Start Windowed." -noborder tells Windows to not draw borders (titlebar, window buttons) around the window.

You can also designate screen size (e.g. -w 640 -h 480), skip the intro video (-novideo), turn on low violence mode in L4D (-lv) and other options that may or not mean anything to you. A fuller list can be found here.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.