Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Recently all my global AddOn data is being ignored when I log in to any of my characters. I noticed since all my UI and add-on settings were as default.

I initially thought that I may have lost all the data due to a crash, but I can see all the files are there in the global SavedVariables directory under my Account directory.

How do I make WoW load all of the data again?

share|improve this question
1  
Did something change about your computer environment (such as moving the installation to a new computer, new directory structure, or something similar)? –  Shaun Mar 16 '11 at 15:35
    
Do those files inside savedvariables actually contain any useful data? or were they just regenerated when you logged in? –  Resorath Mar 16 '11 at 16:42
    
@Shaun No to all of those. –  Simon Hartcher Mar 27 '11 at 11:49
    
@Resorath I can't vouch for all the data but the auction data is there at least. –  Simon Hartcher Mar 27 '11 at 11:50

2 Answers 2

I had this bug a while ago - it happened after W7 updated something. I studied a bit and found that it was related to the registries in Windows, but I'm not sure what. However, disabling and then enabling all addons worked for me, reloading my addons configs.

I know this isn't an answer, but I don't have rep enough to comment ^^

share|improve this answer

Remember that with the introduction of a new patch level to the WoW client all addons are disabled automatically and need to be manually reenabled.
WoW was patched to 4.2 last week of course, so check your addons. Some may work still, others may need updating, a few might need replacement.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.