Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I followed the minecraft wiki on how to set up a new server (extract zip, add name to admin file and run!) however, when i connect through the local client to the server using 127.0.0.1 as my ip (localhost) the local client freezes, and the server reports "Kicking /127.0.0.1: You need to log in!".

But since I was using the local client, I had logged in and I have in fact bought the game. Whats going on? How do I fix this? I am also running the latest version of Java.

Added the server console log

 14:15:10  Setting up
 14:15:10  Loading level
 14:15:10  Now accepting input on 25565
 14:15:10  Level saved! Load: 0/16
 14:15:19  /127.0.0.1 connected
 14:15:24  Kicking /127.0.0.1: You need to log in!
 14:15:24  /127.0.0.1 disconnected
share|improve this question
    
Can the server connect to minecraft.net? –  badp Mar 26 '11 at 14:04
    
it needs to do that? How can I tell if it can talk to minecraft.net? –  Kurru Mar 26 '11 at 14:12
add comment

1 Answer

up vote 5 down vote accepted

Your server needs to connect to minecraft.net so it can verify that everyone who connects has a legitimate and unhacked version of the game. You can test this by using the ping minecraft.net command from the Command Prompt.

However, another option which would open your server up to hackers is to turn off the authentication. In your server configuration file, just add the line online-mode=false and you should have no problems connecting then. However, any hackers could join your server and wreak havoc so be warned.

ADDITION

If that doesn't work for you, ensure that you have the correct minecraft_server.jar file. The correct one can be found ate the bottom of the Minecraft Downloads page. The one on the servers page is often out of date.

share|improve this answer
    
I've tried pinging this which worked fine. I also disabled my firewalls and it still made no difference. Also, adding the online-mode = false didn't make a difference either. –  Kurru Mar 26 '11 at 15:38
1  
You probably downloaded the minecraft-server.jar file on the Servers page of the Minecraft website, rather than the minecraft_server.jar file on the Downloads page of the website. Check my edit for a link to the proper page. –  Weegee Mar 26 '11 at 16:41
    
Thank you so much! That works now! They really should remove the servers page :) –  Kurru Mar 26 '11 at 16:49
add comment

protected by fredley Jan 31 at 16:15

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.