Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Why does Minecraft get stuck when javaw.exe reaches 757.356kb of memory use.

Can I remove this limit or is there anything else I can do to solve the problem?

share|improve this question
    
The game is still in beta so its more than likely just a bug. Check out the Minecraft community maybe log into IRC and ask. minecraft.net/community.jsp –  jb48394 Mar 29 '11 at 13:11
add comment

migrated from superuser.com Mar 29 '11 at 13:20

This question came from our site for computer enthusiasts and power users.

1 Answer

New answer, so everyone can follow the steps:

  1. Open up a notepad.

  2. Type the following:

    C:\Program Files\Java\jre6\bin\java" -Xms2048M -Xmx2048M -jar "C:\minecraft.jar"

  3. File -> Save as. Choose All file types, and save it like: C:\minecraft.bat

  4. Get minecraft's "linux version" at http://minecraft.net. Save it to C:\minecraft.jar [This step is not necessary for jre7 running on Windows 7, you can point the script to minecraft.exe]

  5. You can skip this step if you are running 32 bit windows! Get a 64-bit Java runtime. This wouldn't be a neccessary step, but since Minecraft is a resource hog, you may want to squeeze out all the juice from your computer. You can find the 64-bit version here.

  6. Double-Click the minecraft.bat file.

What does the .bat file do?

  • The first part tells Windows, when you double-click the .bat, it should launch Java runtime
  • The second part is the -Xmx and -Xms part. These are settings for the heap size. Set these according how much memory you have. Explanation for this Heap stuff.
  • The last part -jar C:\... is an argument too, telling Java where it can find the Minecraft.jar launcher.

(Also, check the C:\minecraft.jar, C:\Program Files\Java\jre6\bin\java.exe paths. These things may vary.)


A little extra, performance improvement: (The argument part works only on Windows!)
Add the following arguments to the .bat file: "C:\Program Files\Java\jre6\bin\java" -Dsun.java2d.noddraw=false -Dsun.java2d.d3d=true -Dsun.java2d.opengl=false -Xms2048M -Xmx2048M -jar "C:\minecraft.jar"

This way, we tell Java it should use DirectX to draw. This helped me a lot.

Another improvement can be achieved (Cross-platform!) if you install Java JRE7. It's in a beta state, but perfect for us, playing Minecraft. You only have to modify the .bat file, so it shows:
C:\Program Files\Java\jre7\bin\java instead of the
C:\Program Files\Java\jre6\bin\java (Notice the number in the "jre".)

share|improve this answer
    
If you don't know how to do this, I'll get into the details, just comment on the answer. –  Shiki Mar 29 '11 at 13:31
1  
You should explain your command-line a bit more, for those who aren't used to it. For example, you could explain which part of this command-line modify the memory use limitation... –  Lysarion Mar 29 '11 at 13:39
    
Nice explanation!!! (By the way, i wasn't aware of the JRE7 beta...) –  Lysarion Mar 29 '11 at 14:03
2  
Actually, you will probably see more memory used with the 64-bit jvm than the 32-bit JVM for equivalent heap sizes -- if memory usage is your largest concern, and your desired heap can be satisfied by a 32-bit JVM, you should stay on 32-bit. –  Austin Mills Mar 29 '11 at 17:02
1  
Uncle: No, it uses a library for newbies. Java can draw stuff with both. –  Shiki Mar 31 '11 at 19:24
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.