Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

As a pet project, I would like to use the original Portal to introduce people to gaming.

However, I live in Italy and Italians are culturally not very comfortable with subtitles (not to mention the fact that subtitle players need to be fast readers, as Italian is on average longer than the equivalent English).

So I wanted to change GLaDOS's voice with an Italian version.

However, no matter what I do, Portal does not seem to recognize altered audio files. I tried putting them in %STEAMAPPS%\portal\portal\sound\vo\aperture_ai, and a few other variations on that structure, and double-checked that files were named exactly like in the GCF, but the game simply ignores them no matter what I try.

How can I fix this?

Is there a specific format for the WAV files? Is there anywhere I can check out for error messages?

share|improve this question
    
Does steam 'verify' the files before the game starts? What happens if you remove the original files altogether? –  Mechko Apr 25 '11 at 0:28
    
Also, another thought. Do you own the free version of portal or did you buy it? the paid version includes the sdk while the free version doesn't. –  Mechko Apr 25 '11 at 0:29
    
Answers: a. Steam does not 'verify' before launching. b. Removing STEAMAPPS\portal IIRC recreates it at next launch. c. It's the paid version, but I have no SDK installed. I tried both on Mac and PC. –  millenomi Apr 25 '11 at 10:09
    
Can't you just change Steam's language to Italian and the game will be translated for you? I know I played through Portal 1 in German just by changing the language preferences for the game. –  StrixVaria Apr 27 '11 at 20:56
    
@StrixVaria Portal has full audio support for English, German, French, Russian and Spanish. –  user56 Apr 27 '11 at 21:04
show 7 more comments

3 Answers

up vote 10 down vote accepted

Ha! I did it by cheating: finding an existing sound mod for Portal and examining it :D. Here's how, for posterity:

Apparently, the Source engine does not look for sounds in the directory. It looks for script files instead. Those script files define where to look for stuff.

So I did the following:

  • Opened the main Portal GCF (that's portal content.gcf) file with GCFScape;
  • Extracted GLaDOS's voice script file (that's scripts\npc_sounds_aperture_ai.txt) to the directory where the game engine will look at, which, according to the Valve wiki, is the one where GameInfo.txt is in. So STEAMAPPS\millenomi\portal\portal, so that I have STEAMAPPS\millenomi\portal\portal\scripts\npc_sounds_aperture_ai.txt

Now Portal will look relative to the scripts file for sounds! …not. Apparently, if the file has the same name it's still looked for using the same search path that led Source to pick up the original file instead. Sigh. So, instead, noticing the working mod had file names that were different from the ones in the archive, I changed the script and the filename to a name that wasn't used anywhere else in the game (vo/aperture_ai/00_part1_entry-1__MODIFIED.wav). And BAM!, it worked. :D

share|improve this answer
4  
The bounty is still open in case a better, docs-pointing, not-cheating answer is given. –  millenomi Apr 29 '11 at 7:05
add comment

All you need is to set the correct attributes of your wav file. I have changed files for Alien Swarm, it is also a Source SDK powered game. So I assume the steps are the same:

  1. Get the free application Audacity, install and run it.
  2. Set sound frequency to 44 100 Hz example
  3. Go to audicity options, Formats and select WAV (Microsoft 16 bit PCM)example
  4. Record your sound and export to wav file into proper Portal directory (replace the original file)
  5. Check it in Portal

If you don't hear your sound in Portal then some wav options are incorrect and must be changed. Check the original Portal wav files and see what options are they using (you can open them in Audicity).

share|improve this answer
    
Done so, but didn't work -- GLaDOS keeps using the built-in file. :( –  millenomi Apr 28 '11 at 7:09
    
This is the exact file I'm using: dl.dropbox.com/u/36908/Placeholder.wav -- I'm trying naming it 00_part1_entry-1.wav (to replace "Hello, and again welcome…") and placing it in the folders specified above, but it's ignored. –  millenomi Apr 28 '11 at 7:11
    
Turn off your internet connection. Launch Steam. Replace 00_part1_entry-1.wav with your file Placeholder.wav. Check it in Portal. If you still hear the default glados sound delete the entire folder with its voices. Check that glados is quite now. If not, find all the wav files in your steam folder and delete them. And check now. This is how you will be able to find the file Portal uses for glados sound. –  geotavros Apr 28 '11 at 7:51
    
Note that there is no WAV file outside of the GCF pack -- that is, 00_part1… does not replace an existing file, it is added to a folder. As far as I can Google, this should replace the sound, as the game folder should be searched for replacement files. But it isn't. Or maybe I'm just misunderstanding it. Anyway: no audio files in %STEAMAPPS%\portal before I put one in. She's picking 'em up from the GCF. –  millenomi Apr 28 '11 at 8:25
    
I don't know what GCF is, for Alien Swarm I have just put my files here: ..\Steam\SteamApps\common\alien swarm\swarm\sound\aliens\voc\drone\ –  geotavros Apr 28 '11 at 21:09
add comment

Another idea I have as to why it's not working is that there might be a console option that is preventing mods from occurring.

With your files in the c:\program files\steam\steamapps\millenomi\portal\portal\sounds\vo

With Portal open hit the ~ key (top left keyboard) to bring up the developer console. If that doesn't happen to do anything, click on options. Under the Keyboard tab, there should be a button that says "Advanced". Click that and check the box that says "Enable developer console", then hit "OK".

Now try the ~ key again. This should open the Developer Console. With the developer console open, type "sv_pure 0" (minus the quotes). Then try running a game.

sv_pure is something that is usually used on Multi-player servers like Counter-Strike or Team Fortress 2 which prevents people from connecting to the server using mods (textures/models/sounds). It overrides their mods with the default GCF files.

If this doesn't work, my only other suggestion is to try it again, but remove the second portal folder from the equation.

 c:\program files\steam\steamapps\millenomi\portal\sounds\vo

instead of:

 c:\program files\steam\steamapps\millenomi\portal\portal\sounds\vo
share|improve this answer
    
Good thinking! But no, sv_pure is already at 0. I also tried placing the file in the following folders, where STEAMAPPS is the ...\steamapps folder: STEAMAPPS\millenomi\portal\portal\sounds…, STEAMAPPS\millenomi\portal\sounds, STEAMAPPS\common\portal\sounds, STEAMAPPS\portal\sounds. In each of these directories, the sound was at vo\aperture_ai\00_part1_entry-1.wav. And it was always ignored. –  millenomi Apr 28 '11 at 21:17
    
hmm, what was the structure inside GCFScape for the Portal content? In which the sound files were located. –  Tom Stevens Apr 28 '11 at 21:31
    
Looks like it wasn't a structure problem; see my other answer for how I solved it. :D –  millenomi Apr 28 '11 at 22:12
    
I see, well I know this now if I ever try to do sound mods. –  Tom Stevens Apr 28 '11 at 22:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.