Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

How do I enable anti-aliasing in minecraft?

In some wallpapers I see anti-aliasing, like in this example:

enter image description here

share|improve this question
9  
Are you sure these use in-game AA rather than just an edited screenshot? –  user56 Apr 27 '11 at 13:06
4  
I don't know. But If there is any possible way play with anti-aliasing, it will be great –  LifeH2O Apr 27 '11 at 13:08
2  
That's the point, I'm fairly sure that Minecraft does not support anti-aliasing. –  user56 Apr 27 '11 at 13:10
    
Ah, the irony in playing such a blocky game and wanting antialiasing. –  oscilatingcretin Jul 25 '12 at 20:18
add comment

7 Answers 7

Add the new ultra optifine. You can then enable AA through it in Minecraft. I believe it's under quality.

share|improve this answer
add comment

Another option I have not seen mentioned is using a different '3rd party' launcher that adds visual effects such as Spout or Magic Launcher. They add tons of graphic options and features.

share|improve this answer
    
+1 this is the correct answer. –  Joe the Person Jul 25 '12 at 20:23
add comment

If you have the nVIDIA drivers for Windows, you can force this setting on.

Press right mouse button on your desktop, open the Nvidia configuration thingy, click 3D options (or something like that) and press program option then press "add" and search for minecraft.exe (mine's on my desktop) then:

  • change anisotropic filtering to 16x
  • change anti aliasing gamma correction to On
  • change anti aliasing options to 16xQ
  • change anti aliasing mode to Improve the aplication, or something like that
  • change anti aliasing transpiration to Supersampling
  • change triple buffering to On
  • change maximum pre-rendered frames to 8
  • change texturefiltering anisotropic examples to On
  • change texture quality to High quality
  • change texturefiltering trillinair optimalisation to On
  • change thread optimalisation to On

It made my Minecraft look really awesome, and if your computer crashes, just change all the settings back to the option with the Nvidia logo.

share|improve this answer
4  
This is platform dependent. –  Alain Jun 22 '11 at 20:10
1  
@Alian but it still answers the question. –  Joe the Person Jul 25 '12 at 20:22
add comment

This looks like a different skin. I think that the textures here are much cleaner than the default textures.

I don't think that the picture you found has had any AA applied; You can't enable AA in Minecraft at the moment.

I don't know that the graphics will ever be need to have jagged edges refined :-D

share|improve this answer
2  
Needing anti-aliasing has nothing to do with the "intensity" of the graphics, but is simply a feature to reduce moire or jagged edges. –  Nick T Apr 27 '11 at 21:35
1  
Unless it's an artifact of not being shown at the proper resolution, that first image has definitely had anti-aliasing. The sand/water interface provides compelling evidence, but the better evidence comes from the grass/dirt interface on the right. –  MBraedley Apr 28 '11 at 11:00
    
+1 to Nick T for calling out my poor word choice. –  Kristofer Hoch Apr 29 '11 at 17:18
add comment

You can force Anti-Aliasing via the control panel of your graphicscard, but at this point Minecraft does not play nicely together with Anti-Aliasing. Graphical glitches and artifacts are appearing especially in the water and above torches.

Just compare these two screenshots, first without, second with Anti-Aliasing.

Without AA With AA

share|improve this answer
12  
the water is anisotropic filtering, not anti-aliasing. AA only affects edges not interior textures. codinghorror.com/blog/2006/01/anisotropic-filtering.html –  Jeff Atwood Apr 27 '11 at 22:16
13  
@Jeff Atwood: I expect that Minecraft renders every water block's top as a separate polygon, so it would be affected by polygon AA. –  Kevin Reid Jun 22 '11 at 20:17
    
I do not find any anti-aliasing in second image. Just look at the lower right candle, its edges are as creepy as without anti-aliasing. Though edges of grass near water looks anti-aliased –  LifeH2O Jul 31 '11 at 11:03
add comment

The other answers are correct that Minecraft has no AA support.

Unfortunately I'm at work and can't hit the Minecraft forums for the exact link, but as I recall mod that adds GLSL shaders adds an anti-aliasing setting, but with default textures I notice zero difference. (I don't think this mod is updated for 1.5 yet.)

You also, depending on your graphics card, might be able to force AA on the application externally, but that would probably look awful.

share|improve this answer
add comment

Isn't it just a different skin? You can change skins, including using higher-definition ones.

share|improve this answer
4  
Using a different skin has nothing to do with anti-aliasing. –  Nick T Jun 22 '11 at 22:11
1  
@Nick: of course. –  Lohoris Jun 23 '11 at 7:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.