Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I recently purchased this game and am very impressed, but am about to put playing it on hold until it is officially released and more bugs are fixed.

I can't play the game for more than 5 minutes without the framerate going from smooth as can be to randomly dropping to unplayable levels. I have gotten a black screen more than 30 times so far. Sometimes when I save and load my character appears inside a block and soon after dies.

Is there anything I can do to improve the experience until these problems are fixed? I hope so as I love this game apart from the bugs! I cannot be the only person out of the millions of people who have this game who want to play it but cannot due to lag and crashes.

my specs are

Windows 7 64-bit
4 GB RAM
Intel Core 2 Duo 2.53 GHz
NVIDIA Quadro NVS 160M 256 MB

EDIT: I have tried setting the graphics down lower and the draw distance to shorter, and it helps a bit, but I still have lots of problems with lag and crashing.

share|improve this question
1  
The lag may be caused by the draw distance. It'll take a while for it to work it's way up to being 'far', so you might want to turn that down. I've never had any crashing though. –  Ullallulloo Apr 27 '11 at 21:59
    
I never have problems, but my machine is way beefier than yours. I agree that maybe you should turn the draw distance down. –  Shinrai Apr 27 '11 at 22:34
    
FWIW, I've got a decent quad core coupled w/ GTX460 and it crashes regularly for me as well. I have no framerate issues or drawing distance hits, but many crashes. I probably would have quit playing, but I started playing on a friend's server. It didn't help the crashes, but at least I stopped losing items and spawning in strange places because my location and inventory are stored on the server. –  Uninspired Apr 28 '11 at 0:03
1  
Does pressing f actually change the draw distance or does it just change the fog distance? –  da code monkey Apr 28 '11 at 0:48
2  
Is your JVM up-to-date? –  SevenSidedDie Apr 28 '11 at 20:30

8 Answers 8

up vote 4 down vote accepted

I have switched to playing Minecraft under Ubuntu, and most of the more annoying problems simply don't occur anyone. I can finally enjoy the game!

share|improve this answer
3  
that's the spirit :) –  Zommuter May 1 '11 at 10:41

The first thing I'd do would be to delete your current profile and rebuild it by logging into the game client.

You can delete your data by browsing to your %APPDATA% directory and deleting the '.minecraft' directory.

If you don't know you %APPDATA% directory, then click on Start, and type in 'cmd'. When the console appears, type in 'echo %APPDATA%'

Hope this helps. I've not had any problems like this with the 1.5 client.

"Also be aware THIS WILL DELETE YOUR WORLDS. Back them up first! – Shinrai" +1 for remembering that Shinrai

share|improve this answer
    
In newer versions of Windows you can just type '%APPDATA%' into the address bar in Windows Explorer and it'll TAKE you there...no need for the workaround. This should work for any environmental path variable. –  Shinrai Apr 27 '11 at 22:35
10  
Also be aware THIS WILL DELETE YOUR WORLDS. Back them up first! –  Shinrai Apr 27 '11 at 22:36

as @Ullallulloo mentioned, draw distance is a HUGE factor. just toggling that from Far to something closer has had a huge effect on my system. for reference, i'm on a 2006 mac pro with a four 2.66 xeon cores, 6GB of RAM and a slightly long in the tooth geforce 8800.

i'm not sure how the game is working behind the scenes, but through my own exerimentation on this and slightly older systems, the draw distance seems to render anything that you could conceivably see, as long as it isn't occluded by some other object. for new worlds/other places where you're seeing terrain for the first time, drawing all this can really cause things to bog down. it might not even be something that you, the person playing, can see, as long as you, the avatar in the gameworld, has it in their field of vision, it gets rendered.

when i'm exploring new areas, having the FPS drop to see more of where to go is an acceptable tradeoff, i'll turn draw distance up. when i'm working in one area and not moving much, i'll turn it down, as i don't need to random dips as the game draws places i'm not interested in at the moment.

share|improve this answer
    
Does Minecraft perform view frustum culling and hidden surface removal? –  da code monkey Apr 28 '11 at 0:47
1  
@dcm As of 1.5 the game does basic culling. In 1.4 and earlier it drew everything in draw-distance regardless of visibility, including everything below ground. –  SevenSidedDie Apr 28 '11 at 2:50

As many of the other responders have said, changing the Render Distance to Normal and the Graphics to Fast can help the lags and crashes. It is also possible that incompatible mods are causing the crash.

As far as the spawning problem, try installing the mod Single Player Commands. With that, you can choose where to spawn by pressing t, then typing in setspawn and hit enter. Then whenever you die or go to "home", you will spawn at that set point.

PS: When you do the setspawn, place it in an open area so you don't get stuck. And If you have it in the sky, make sure that you acivate "fly".

share|improve this answer

Another thing no one has mentioned: Minecraft has a lot of problems using the x64 (64-bit) version of Java. Try using the x86 (32-bit) version instead.

share|improve this answer
    
Dang! I was hoping that switching to the x64 version might help. –  Kara Marfia Aug 15 '11 at 15:48

There are many tutorials about optimizing performance, and they all recommend allocating 1GB or more. It doesn't work for me (I only have 1GB in total), just use their scripts, but edit the RAM allocated to be:

  • 256MB, for only small mods and no HD textures
  • 512MB, in case 256MB lags.

With 256MB, I can play on SMP with Tehnic Pack (default texture pack) without any lag or out-of-memory errors.

128MB is playable, but will generate OOM errors.

share|improve this answer

Go to your Roaming folder by typing in %appdata% in the Windows Search bar then go to .minecraft after you are there find a folder called options.txt and open it. Inside options.txt find the peice called Fps Limit: 0 and change it to Fps Limit: 2050 it will make Minecraft run with less lag

share|improve this answer
1  
Generally the FPS limit restricts how many frames are rendered per second. Is this not the case for Minecraft? You seem to be saying that no limit is worse than trying to render over 2000 frames per second (which seems beyond the limits of most modern hardware). Is this a bug in Minecraft? –  PeterL Oct 8 '12 at 12:51

Put 'Performance' to Max FPS. Also it wouldn't hurt to switch 'render distance' down to normal or tiny and set graphics to fast.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.