Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

no longer applicable for minecraft versions beta 1.6 and later

While playing on a Minecraft SMP bukkit server, I tried using the /thor command to manipulate lightning on a few pigs with my pickaxe.

lightning on pigs

But it seems that I can't kill it, I even tried putting them in a pit and hitting them with a diamond sword, to no avail. However, they still make the damage sound.

zombie pigmen in a pit

I even tried using the /butcher command provided with WorldEdit, but it still would not work!

/butcher does not work

So, how do I kill the zombie pigmen?

EDIT:
I know that restarting the server, unloading the chunk on the server etc. will despawn the mob, but what I want to do is to kill it. So,

  1. Is this a bug?
  2. Does it happen in other servers?
  3. What can I do to fix it?
share|improve this question
1  
You could always just bury them, and forget about them. –  DwarfSlice May 15 '11 at 15:20
3  
Burying them alive is cruel, I prefer killing them swiftly :P –  user8949 May 15 '11 at 15:24
9  
Might this be a client-server bug? Perhaps the zombie pigmen exist only in your client—since damage is server-side, you wouldn't be able to kill them. Disconnecting and reconnecting would fix it, if that's the case. –  SevenSidedDie May 15 '11 at 15:39
    
Had to ask: Texture Pack? –  fredley May 15 '11 at 22:42
    
the texture pack is SimpleCraft. –  user8949 May 16 '11 at 0:08

3 Answers 3

up vote 14 down vote accepted

This is a glitch with Minecraft that it also spawns multiple pigmen from one pig. The easiest way is to disconnect and reconnect. They should disappear.

This has happened in my server.

And it IS a client side bug like SevenSidedDie said.

share|improve this answer
    
+1 -- 13 hours with no second answer and then we answer the same within 52 seconds... –  Zommuter May 16 '11 at 5:05
2  
1  
@SevenSidedDie: Why don't you post that as an answer then? –  Ullallulloo May 25 '11 at 14:52
1  
@Ull I think SmilingDevil covers the "it's a bug" answer just fine, and I'm happy to just contribute to it. :) –  SevenSidedDie May 25 '11 at 16:16
    
@SevenSidedDie: pssh, you're too nice. :) –  Ullallulloo May 25 '11 at 16:23

I had the same issue with invulnerable pigs appearing client-side only from a chicken spawner. Dis- and reconnecting makes them vanish. This is a bug, you cannot kill them.

share|improve this answer

Try getting everyone on the server to leave the area, and come back. The easiest way I can think of to achieve this if there are a lot of people playing is to try a server reset. This should cause them to despawn.

Edit As I've found out on my own server, this is purely client-side. Logging out and back in should make them disappear.

share|improve this answer
    
I had a similar experience, but it's not necessary for anyone else to disconnect since this bug is client-side –  Zommuter May 16 '11 at 5:06
    
-0 - since bckbck accepted SmilingDevil's answer, yours is incorrect (in this case) and its execution would be unnecessarily inconvenient for players. Then again, this could help for other issues so I won't downvote either –  Zommuter May 18 '11 at 5:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.