Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I just got The Witcher 2 today and so far it seems quite enjoyable. The problem is that I haven't been able to play much of it so far due to lag that occurs even on low settings. The game recommends that I play on High, but this simply isn't possible; the game pauses every time I so much as turn Geralt's head. Any idea what's causing this problem and what settings I might need to adjust to get the game working at a normal, mostly lag-free speed?

My graphics card is the NVIDIA GeForce 9600 GT, and I have 4 GBs of RAM on my computer. My graphics driver is beta driver 275.27. All display specs can be found here(results from running dxdiag).

share|improve this question
3  
As always, one of your steps should be to try running in a lower resolution. –  StrixVaria May 20 '11 at 1:22
    
@Strix Ah, didn't know that! This is actually the first time I've had troubles running a game because of graphics in a fair while. –  Mana May 20 '11 at 1:25
    
@Strix Yeah, running at 1400x900 instead of the full 1920x1080 definitely helped. –  Mana May 20 '11 at 1:48
    
Make sure you uninstall the 3D Vision driver, it is said to cause significant problem. –  Mad Scientist May 20 '11 at 6:10
    
This game is probably too stressful for a 9600GT at that resolution, yeah. It's just not quite fast enough a card. –  Shinrai May 20 '11 at 15:55
show 2 more comments

1 Answer 1

up vote 3 down vote accepted

I made the following adjustments:

  • Installed the latest beta driver from NVidia's website (version 275.2something)
  • Adjusted the screen resolution from 1920x1080 to 1360x768.
  • Uninstalled the 3D Vision driver
  • Updated to Patch 1.1, which removes all DRM(apparently a cause of slowdown up to 30% on lower-end systems)

The game plays at around ~16 FPS on High settings with occasional bursts of lag when entering new rooms, and plays at a much more enjoyable 28 FPS on Medium.

share|improve this answer
2  
Obviously you want to play at 800x600 at Wireframe settings. –  badp May 21 '11 at 19:30
    
How did 1920x1080 with Low settings work? –  Iain Feb 25 '13 at 14:49
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.