Sign up ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Searching on Google for terms Radeon, Vsync and Stuttering gets a lot of results of people documenting the problem (not just with 11.5, but going a few years back too). But I couldn't find any solutions.

When running any OpenGL app with Vsync enabled, in windowed mode, I get highly noticeable stuttering every second or so.

Turning off Vsync removes said stuttering (the FPS then exceeds 60 by a large margin).

I'm running Windows XP, Catalyst 11.5 and Radeon HD 4650. Desktop resolution of 2560x1600 @ 60 Hz.


share|improve this question

3 Answers 3

Vsync uses a lot of system resources, furthermore it uses ratios in relations to your screen refresh. Typically most LCDs run at 60Hz, some support 75Hz (but are often only running at 60Hz). Why this is important is Vsync clamps your FPS to a ratio of your refresh. If you can reliably get 60FPS it will clamp it to that, but if it ever drops down below that (even by 1 FPS) it drops down to 30FPS (1:2 or 1/2 of your refresh rate), and if it drops below that it will drop to 15FPS (1:4 or 1/4 of your refresh rate).

The reason this happens is because Vsync is designed to eliminate any screen tearing effect. This effect is more predominant on LCD screens, and less so on CRTs. Vsync also adds measurable input lag compared to having it disabled.

Unless you have a very good reason to run Vsync it's typically not a good idea to run. It chews up far too many resources for a marginal benefit. If you want to see a bigger benefit to your gaming (or video) experience, get a 120Hz LCD monitor and run it at 120Hz (I do not mean to use it for 3D purposes, I mean to use it for 2D purposes). Getting a good 120Hz monitor will be far smoother than running Vsync and not rely on such a hog of resources. Such a monitor looks best however if you can reliably maintain 120FPS or more.

All in all, I recommend you do not use Vsync.

share|improve this answer

You should probably also set the Flip Queue Size to 1 or 2 from its default value "undefined".

As fair as I remember it needs a change in the registry.
One of the tools that do this for you is Ray Adams' ATI Tray Tools.
You can download the latest version right here.

share|improve this answer
Thanks, but I don't want to use Triple Buffering, even if that fixes the issue. I prefer double buffering. Enabling it in Catalyst settings has no effect on the issue. I have another computer with Nvidia GTX 260 and it handles the same scenario as expected, no stuttering with or without Vsync. Where do you change Flip Queue Size? I don't see that in Catalyst options. Am I the only one experiencing this problem, or is it affecting everyone with AMD video cards? – Dmitri Shuralyov May 29 '11 at 20:03
You can change neither the Triple Buffering (for D3D, the checkbox is only for OpenGL) nor Flip Queue Size (FQS). FQS can be changed either with a Registry Hack, which I don't remember, or more comfortably, by using the tool I mentioned in my answer. – DrFish May 29 '11 at 20:25

You can change the flip queue size for ATI cards by adding a new key in the Windows registry.

Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4d36e968-e325-11ce-bfc1-08002be10318}\000[n]\UMD, where [n] is the number of the adapter, probably 0 on most systems.

Add a new binary key called FlipQueueSize. As far as I understand, the default value is 33 00, a queue of 3. Change it to 31 00 or 32 00 for a queue depth of respectively 1 or 2. For me this changed the unexplained stuttering in The Witcher 2, but I do not know if it will have a negative effect on other games, yet.

If needed, you can always just remove the registry key, as its default value is set elsewhere in a .dll file.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.