Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

This game won't run on anything with OpenGL lower than 2.1, and I have all the latest software from ATI installed and I get OpenGL 1.1

How can I update the OpenGL or get the game to run?

share|improve this question
    
What driver version are you using? –  Oscar Cheung Jun 3 '11 at 4:21
    
Crap...I'll tell you tonight, I'm at work now and the laptop is home. –  rdrgrtz Jun 3 '11 at 12:40
    
@Oscar 8.635.0.0 (8-4-2009) –  rdrgrtz Jun 3 '11 at 23:32
    
One more thing: what OS are you using? –  Oscar Cheung Jun 6 '11 at 2:12

1 Answer 1

up vote 3 down vote accepted

Solved! After days of downloading different drivers for my video card, I decided to start from scratch, so here's what I did:

  1. Went to "Manage" system on the "My Computer" icon (right click for menu), and then "Device Manager"
  2. Uninstalled the driver on my video device.
  3. Restart and then go to AMD/ATI website to look for the new drivers.
  4. Instead of downloading the 57MB file (the Catalyst Control), I downloaded a 935KB file that scans your system and decides the best driver. So this downloaded the correct driver and voila! all fixed!

Now Tactics and Duels of the Planeswalkers are working great and I got OpenGL 3.3 :D

share|improve this answer
    
Yeah, I was about to say that you should download the Catalyst drivers (currently ver. 11.5), but glad you solved it. –  Oscar Cheung Jun 6 '11 at 3:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.