Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I downloaded the latest version of the MAME Emulator (version 0.142 - mame0142b.exe) from the address below recently:

http://mamedev.org/release.html

Unfortunately, when I execute the mame.exe file from the command line it just crashes (screen goes black for a second, then PC reboots by itself - no error is shown). I've tried running it without any ROMs, but still got the same problem.

I have the latest drivers installed (275.33) for my NVIDIA GeForce 6100 nForce 405. I am using Windows XP Home SP 3.

Could you please advise how to get the emulator to run without crashing?

Here is the error I received (after disabling automatic restart):

Technical Information:

STOP: 0x0000008E (0xC0000005, 0xBD1B1642, 0xB1078658, 0x00000000) nv4_disp.dll - Address BD1BD1642 base at BD012000, DateStamp 4dd7387f

share|improve this question
    
When your computer reboots without showing an error, it's usually just because it is told to supress the blue screen. Try following the instructions here to allow the blue screen to appear so that you may get a lead on the driver/device guilty of the crash: tunexp.com/tips/maintain_your_computer/…. Alternatively, all critical system failures should be present in the event log: support.microsoft.com/kb/308427 –  Aubergine Jun 4 '11 at 13:49
    
I have set my computer to not reboot and show the error instead. More helpful for troubleshooting. –  Goto10 Jun 8 '11 at 17:03
add comment

4 Answers

up vote 1 down vote accepted

A video driver bug is the most likely culprit. Try running mame in a window instead of fullscreen with the switch -window. You could also try -video gdi.

share|improve this answer
    
I tried it with -window but unfortunately still got a BSOD. –  Goto10 Jun 8 '11 at 17:04
    
@Goto10 did you try it with -video gdi? –  Hugh Allen Jun 8 '11 at 23:51
    
I tried -video gdi and MAME ran fine (tried several times)! Many thanks for suggesting this. Is there any way to have this switch added automatically, without having to manually include it each time a game is run? As if I run MAME and forget to add this, or just make a typo, then it is going to be a BSOD again and restart. –  Goto10 Jun 11 '11 at 13:55
    
If I run MAME with -video gdi -cc (just the once), this creates a mame.ini file in the same folder as mame.exe, with video set to GDI. So I can run MAME for a game in GDI mode every time without needing to specify any switches. Still uncertain why it won't run with the default of d3d though. –  Goto10 Jun 11 '11 at 19:24
add comment

I recently had this problem too with MAMEUI32 and MAME.

The cause of the fault in my case was with MAME's DirectX9 video mode. MAMEUI32 (and I assume MAME) offers the following display modes: GDI, DirectDraw, DirectX8, DirectX9.

Only DirectX9 (i believe the default mode) reset my computer. All others work. Personally, I preferred the DirectDraw setting. I use this along with the non-hardware stretch setting, as this - though blocky - is kinder to my eyes.

If you plan to download the latest MAMEUI however (.143), note it suffers from long load-times. There are discussions on-line to help circumvent this. However, I am sticking to my old .130 version which works well.

share|improve this answer
    
Thanks for your answer. I've stuck with the 0.142 version for now, and use the GDI mode. I have had no crashes since using it like this. But the default setting crashed my PC every time - forcing a reboot. –  Goto10 Aug 7 '11 at 9:48
add comment

There's a known issue that causes crashes when you combine recent MAME builds, certain Nvidia graphics cards, and the latest Nvida drivers. The only known solution is to roll back your video drivers to an older version, usually, several versions back.

More info in these threads...
http://www.mameworld.info/ubbthreads/showflat.php?Number=280706
http://forum.arcadecontrols.com/index.php?topic=111834.0

share|improve this answer
add comment

Hey man, I'm having the same problem and am reinstalling all of my video drivers, with different types for a guess and check approach. I'll be working on my computer until it's fixed so I'll let you know if I come up with anything that worked for me. My specs are similar to yours. I'm running Windows XP with a 6200 Nvidia Graphics card. Try to right-click on the MAME executable and go to Properties to see if you can run it in compatibility mode for Windows 95. Running it in a smaller window or in 256-color mode will usually bring up an error if you have the same problem as me.

share|improve this answer
    
I have had several attempts but cannot get it working. Have you had any success? –  Goto10 Jun 8 '11 at 17:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.