Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Is there any way to disable the auto pause that takes you to the menu screen?

I play Secret of Monkey Island: SE in windowed mode. Whenever I click on something outside the window, the game will automatically pause and go to the menu screen. I have a dual monitor setup, and I want to play Monkey Island on one screen, and work on something else in the other without having to constantly pause and resume the game.

Edit:

I found a helpful Stack Overflow link that may be of use in writing a Monkey Island Un-Pauser program.

share|improve this question
    
Monkey Island 2 SE has the same behavior. I don't know if it's possible to change however. –  sippa Jul 16 '10 at 23:25
    
@sippa Thank you for posting this as a comment instead of an answer. Why are there so many answers on this site that begin with "I'm not familiar" or "I don't know" and "Maybe"? –  Christian Jul 30 '10 at 15:13
add comment

2 Answers

up vote 1 down vote accepted

I'm not familiar with how message passing works in Windows, but there may be a way to prevent loss-of-focus messages from reaching the game with an external program.

If you need assistance with writing such a program, remember there's always StackOverflow!

share|improve this answer
    
Yes! This sounds very interesting. I will look into it and let you know if it works. Thanks! –  Christian Jul 18 '10 at 16:34
    
I'm accepting this answer because it seems the only way to solve this problem. I've since beaten the game and am no longer really worried about it, but I didn't actually end up writing the monkey island un-pause program. –  Christian Jul 30 '10 at 15:02
add comment

I don't know if this is the same problem you are having, but you could try the solution found here:

Open Task Manager
find MISE.exe in the "processes" list.
Right click it and then click "Set Affinity..."
Uncheck the checkbox next to all CPU cores except for one (it doesn't matter which one you leave checked, as long as only one is checked).
Play Game!

If this works, and you don't want to do this every time, more information can be found in the thread to edit the program and make this solution permanent (i would obviously test it first before doing that)

share|improve this answer
    
Thanks, but this isn't the issue I'm talking about. Instead of the game randomly pausing itself, I am the one causing it by clicking outside the game window. –  Christian Jul 16 '10 at 18:50
    
is that a feature of the game? –  Josh K Jul 16 '10 at 19:04
    
Why would you ever need to pause an adventure game? It is a bug. –  Christian Jul 16 '10 at 19:11
    
In that case the multi processor thing could still be the issue behind it, you could test it (looks like a quick test) and see if it works is all im saying –  Josh K Jul 16 '10 at 19:17
    
Thanks for the answer. I did try it out before my first comment, and unfortunately it didn't solve the problem. –  Christian Jul 16 '10 at 19:24
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.