Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to use Blizzard's SystemCheck tool to opt-in for future Blizzard game betas.

When I run it I see a page with my system information, but when I click "send" I get the error:

There was a problem sending your system information to Please check your internet connection, close all applications and try again. For further assistance, please visit

And in addition my browser opens on this page, which looks like an attempt to send me to a support page further explaining the problem, but it's actually just an error page.

The specific tool I am using is named SystemCheck_enUS.exe, downloaded recently from my personal account page on If it makes any difference, I'm running Windows 7 and I'm not located in North America.

share|improve this question
Do you have a firewall and have you tried with it disabled? – Matthew Read Jun 13 '11 at 13:28
The tool has worked fine for me in the past. This might be a better question to ask on Blizzard's tech support forums or on SuperUser. – Adam Lear Jun 13 '11 at 16:57
@Anna I think this definitely belongs here more than SuperUser. And I have more confidence in this site than in Blizzard's tech support :) but I'm also checking other places, of course, and I'll update here if I find anything. – Oak Jun 13 '11 at 17:00

If you're using "plus addressing" in your email address, try taking it out. That's what worked for me. Until I made the change, I would get the same exact error as you.

SystemCheck didn't work with:


SystemCheck worked with:

share|improve this answer

Blizzard's troubleshooting page has this to say

Why is the Beta Opt-in application giving me an error message when I try to submit my information?

First, verify that you have a stable internet connection when attempting to access a website. If you are able to access websites, you may have a firewall preventing the information from being sent to us. Please make sure there are no firewall(s) blocking the opt-in application from sending us your system information. Downloading a fresh copy of the SystemCheck application may be the answer if you are still seeing a failure message after verifying the connection is stable.

share|improve this answer
up vote 0 down vote accepted

I've re-downloaded the tool again (for the 20th time, more or less), and this time it worked, so problem solved. This might be related to me resetting the language before downloading the tool this time, as explained in the bottom of the troubleshooting page, but I can't be sure.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.