Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Why would one want to do this since one may as well just run the game full screen? Well, I will tell one why one would want to do this.

I have to turn vsync on to eliminate jagged-edge artifacts that occur while panning from side to side. One of the downsides to doing this is a slight degree of mouse lag that, for me, renders the game almost unplayable. While playing Portal 2 a few weeks back, I learned that running the game windowed at 1920x1080 actually eliminated the mouse lag introduced by vsync. Not only that, you couldn't even tell it was running in windowed mode.

I tested running Duke Nukem in windowed mode and, much to my delight, the mouse lag issue went away. However, Duke Nukem's max resolution while windowed is something like 1600x900 (if that's wrong, I'll edit this as soon as I get back from my next playing session).

If I could get this to run in a 1920x1080 window, I'd be one happy Duker.

I found system.ini and located the spot where it contains the window size and resolution, but it's all funky. In Notepad, there are spaces in between all the characters in the file. In Notepad2, there's a NUL. Editing this file in either text editor appears to corrupt it. Any ideas how to get around this?

share|improve this question
    
I found a work-around, but it may only work with Nvidia cards. Open the Nvidia Control Panel, create a profile for Duke Nukem Forever, force vsync and triple buffering on, and turn off vsync within the games video settings menu. I have a 480 GTX, so your earlier graphics cards may not have Nvidia Control Panel. I still get a crappy framerate, though. It's not my card, but rather appears to be related to poor game engine design. I could definitely be wrong, but Bioshock 2 was FAR more demanding than DKF and runs like liquid with all settings maxed. Oh well. –  oscilatingcretin Jun 22 '11 at 22:58
    
This works with any Nvidia card that can run DNF. I do believe ATI has the same option. –  user56 Sep 17 '11 at 16:25

3 Answers 3

Edit the system.ini file with a hexadecimal editor like HxD. I'm not sure will this help or not, because I don't have DNF, just telling how to edit the file.

Additionally you can try launching the game with screen resolution set in command line arguments. Right-click DNF in Steam, press Properties, click Set launch options and put the following line: ResX=1920 ResY=1080

share|improve this answer

Try adding -window or -w to the shortcut path. Right-click on the shortcut located on your desktop and go to properties. In the target path field, go to the end of the address and type it in. This works for most games, but some games do not and there can be graphics performance issues. I don't have Duke Nukem, so this is just a tip from other games I've used.

share|improve this answer
    
AFAIK Unreal Engine 3 doesn't use -w and -h, it uses ResX=width ResY=height instead. –  SiPlus Jan 16 '12 at 12:09
up vote 0 down vote accepted

I found a work-around, but it may only work with Nvidia cards. Open the Nvidia Control Panel, create a profile for Duke Nukem Forever, force vsync and triple buffering on, and turn off vsync within the games video settings menu. I have a 480 GTX, so your earlier graphics cards may not have Nvidia Control Panel. I still get a crappy framerate, though. It's not my card, but rather appears to be related to poor game engine design. I could definitely be wrong, but games like Bioshock 2 and Skyrim are FAR more demanding than DKF and they run like liquid with all settings maxed. Oh well.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.