Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have an Nvidia 480 GTX, a video card powerful enough to play games like BioShock 2 with all settings turned up to the max and still deliver super smooth FPS.

When I play DNF, though, it has choppy gameplay and terrible framerates. Even with AA turned off, it's still terrible. I googled this issue and it appears that lots of other people are having this problem, but no one has offered any real answers on how to get smoother FPS.

So is there an actual solution to this?

share|improve this question
3  
This feels like a rant more than a question... –  Raven Dreamer Jun 24 '11 at 2:29
1  
My GTX 460 plays it just fine. –  Shinrai Jun 24 '11 at 2:48
3  
@Oscilatingcretin - I didn't say there wasn't a question; I merely wondered if it was necessary to ask it in such a roundabout, passive-aggressive way. –  Raven Dreamer Jun 24 '11 at 3:07
3  
I've removed everything irrelevant to the question. I'm sorry, but this is a Q&A site, not your blog. –  BlueRaja - Danny Pflughoeft Jun 24 '11 at 7:37
1  
Could you add your system specifications? Your vidiocard is not the bottleneck for sure, but there is a good change you lack somewhere else. Might be anything from low MEM to slow CPU to slow mobo. –  Dorus Jun 24 '11 at 13:40
show 4 more comments

2 Answers

up vote 5 down vote accepted

The answer is simple- turn your DNF graphics settings down. If performance is still unacceptable, you will need to upgrade either your video card or your computer itself (i.e. the Motherboard/Central Processor/Ram). In your case, the bottleneck is not likely to be the video card, so better framerates can be achieved by getting a more powerful CPU.

It is of note that different games tax a processor differently. When comparing any 2 games, less exquisite graphics do not always equate with faster FPS. Some games are more processor intensive, generally for reasons other than graphics. The operative fact is that, if other gamers with your video card can achieve better framerates than you, your FPS bottleneck is not in your Video card.

And finally, if no matter what you do, you cannot bring yourself to enjoy the look of DNF, perhaps you will find something to enjoy in the game's voiceovers, ideas, or even gameplay.

share|improve this answer
3  
+1 for CPU, a lot of gamers don't seem to understand how important that is. With my 1.8 GhZ Athlon 64 x2, I got about 5~10 fps in Prototype; after upgrading to a 3.2 Ghz AMD Phenom II x4, I get 50~60 fps. –  BlueRaja - Danny Pflughoeft Jun 24 '11 at 7:42
1  
Phenom II x4 955 FTW! –  Ragnar Jul 7 '11 at 5:45
    
I haven't verified this answer, but I am marking it since it appears to be the best. I have an i5 processor. Still, I find it odd that any game that relies on 3D acceleration in this day and age would rely strongly on CPU unless we're talking physics-intensive processing (Crysis, for example). I don't recall anything about DNF appearing to try to take advantage of physics. It was a fairly bland game on the visual scale. –  oscilatingcretin Jun 12 '12 at 2:09
add comment

Make sure you did all common things like:

  • Update (vid/mobo/sound/bios) drivers & install patches.
  • Close background applications.
  • Turn down/off all graphic settings.
  • Lower screen resolution.
  • Check CPU/MEM usage during the game, is one maxed out?
  • Try to disable drm/steam etc.

Once you made the game run smooth, start turning up res and other graph settings again one step at the time. I suggest you aim for at least 30fps.

If all fail, you probably have a hardware bottleneck somewhere.

Edit: I tried the same myself, runs just fine. I just realized the problem might be drm related. Try to disable it the ... eerhm, usual way.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.