Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I have an 1-year old 27'' iMac (8GB RAM) and am using Parallels Desktop 6 to virtualize a Windows XP installation. This is its dxdiag output: DXDiag output While Games like Civilization IV work without any problem I get some strange artefacts when trying to play games like Risen or Gothic IV. While the main GUI (and the initial dialogs when starting the game) is colored correctly (see the text at the center and the health bar at the lower part) the main game is black and white. The performance is great, just all of the textures are missing: Screenshot As nobody at the Parallels forum could help me I am trying to find someone here who has an idea what the problem might be.

Thank you in advance!

share|improve this question
    
If the textures are indeed missing and not being rendered incorrectly, maybe you can append that folder path to an environment variable. PATH comes to mind... –  Robb Jun 24 '11 at 19:49
    
@Robb this neither occurs on only one game nor on one version (tried Steam, full game and demo one) so I don't think it does not find the textures on all those games. What does the Path environment variable has to do with this? As I know its (only) purpose is providing paths for executables, isn't it? –  muffel Jun 24 '11 at 20:23
    
PATH also contains paths for shared libraries (unix) and dlls (windows). I compile code with a lot of additions to my PATH env var. My logic is this: Textures are (sometimes) loaded via a plugin which is called upon when requested by the game. If it can't find the plugin OR the plugin can't find the textures it could be a pathing issue. A lot of apps use the environment variable PATH to do its searching. That being said, typically unix keeps PATH to binaries and uses LD_LIBRARY_PATH as its dynamic loading path var. –  Robb Jun 24 '11 at 20:28
    
It was merely a suggestion, if you don't think that will solve the issue don't concern yourself with it. –  Robb Jun 24 '11 at 20:34
    
@Robb I tried to add all related paths to the variable, but unfortunately it doesn't help at all, thanks anyway! While trying to search for related issues I discovered that users of Crossover has similar issues while it's a complete different type of execution (virtualization over emulation). –  muffel Jun 25 '11 at 9:52
show 2 more comments

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.