Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

On my Mac Book Pro 15" the screen is corrupted when I try to launch BIT.TRIP RUNNER. The game appear to launch correctly as I can hear the game music after some time (probably time to load the game), and I can quit it using ESC key.

After looking in the Steam forum (first topic, second topic), it appears to be caused by a default resolution that is not supported by the monitor, and the solution is to change the resolution used by the game, or to switch to windowed mode by using ALT+ENTER (does not work on Mac).

However, the path given in the thread is a Windows path. So I'd like to know what is the equivalent path on the Mac platform.

share|improve this question
add comment

1 Answer 1

up vote 4 down vote accepted

Ok, using dtruss, I was able to figure out the name of the configuration file loaded by the game. It is located in ~/Documents/BIT.TRIP RUNNER/game.cfg and contains the following:

Fullscreen = yes
Resolution = 1280x720
WindowSize = 1280x720
VSync = yes
EnableVibration = yes

I tried to set the Resolution to the native resolution of my Mac Book Pro 15", 1680x1050, however the display was still garbage (but at a larger resolution so I knew that my modifications were taken into account). I then tried to change Fullscreen to no and the game launched in a windows, but with correct display.

So now, I can play when the file contains:

Fullscreen = no
Resolution = 1280x720
WindowSize = 1280x720
VSync = yes
EnableVibration = yes

Update, after experimenting a little in the option, it appears the game use the format 1680x1050x32 for the 32-bit version of a given resolution, otherwise it try to use a 16-bit version. And it seems that 16-bit resolution are not supported (at least not with version 10.6.8 of Mac OS X).

So the final version of the configuration file allowing me to play in fullscreen mode to this game is:

Fullscreen = yes
Resolution = 1680x1050x32
WindowSize = 1280x720
VSync = yes
EnableVibration = yes

To find the best resolution for your Mac, I'll recommend to follow this procedure:

  1. Go in System Preferences > Displays and note the resolution used;
  2. Change the configuration of the game to be in windowed mode;
  3. Launch the game, go into the options, and change the resolution to the resolution noted, in 32-bit mode, select fullscreen;
  4. Relaunch the game, it should work, otherwise return to 2. and see if there are other resolution near the one you want.
share|improve this answer
    
Thank you. This absolutely saved my life! I'm on a macbook pro 13" and after some messing around I found you need to use Resolution = 1280x720x32 @ 60Hz and WindowSize = 1280x720 to get it working there. –  user10905 Jul 5 '11 at 5:00
    
FYI, for Ubuntu the config file is at ~/.gaijin_games/bit.trip.runner/game.cfg. –  Mu Mind Oct 13 '12 at 22:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.