Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I've built an underground minecart track to allow me fast travel between two outposts. In the middle I've placed a powered rail, with a long redstone line to each post. I connected these two to a device with two inputs, and one output. When one of the inputs change, so does the output, effectively allowing me to turn the underground powered rail on and off from my outposts, acting sort of as a station. I recently hooked up this device's output to the input of another one of these devices, making the other input a lever so that I may also control the power to the rail from underground.

It powers up perfectly, but when I try to turn it off, it simply won't, even when destroying all redstone wires to it. How can I fix this?

share|improve this question
    
Basically, you have an XOR Gate controlling the circuit? If you've wired it up correctly and have verified that the problem isn't the logic gate, perhaps the Redstone Dust that serves as the inputs into the gate accidentally touches the powered rail at some point? Maybe there is (for some reason) a stray Redstone Torch powering the rail somewhere. –  Kevin Y Jul 5 '11 at 19:43
3  
Could you post a screen shot of your wiring? It might help diagnosing the problem. –  Michael Jul 5 '11 at 19:57

2 Answers 2

It sounds like a problem with this 2in/1out "device". I would do two things:

1) Try setting it all up in a smaller area and see if the problem persists. There might be some game bug or design flaw caused by the long distance. Also it will be easier to do "debugging" on the circuits if it's all collected in one place.

2) Post a schematic of the device since it is very hard to help without seeing the actual circuits.

Update:

From patch notes for latest patch 1.7.3

Booster rails are no longer being powered magically without a power source

So updating your client might fix the problem now.

share|improve this answer
    
My understanding is that the rail is staying powered. Even if the xor gate is bugged, breaking the connection to the rail should turn off the rail. @Ernie, we'd all appreciate some followup. –  Arkive Jul 6 '11 at 15:31

From the Bugs section of the powered minecarts page over at the Minecraft wiki,

  • When you power a track, 8 tracks in both directions (excluding the track being powered) will be powered.

  • If you place a powered rail 1 block above 2 powered rails at a corner, the powered rail at the corner becomes powered

Either of these could cause the behavior you describe.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.