Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

When I try and play the PC version of Dead Space the mouse is sluggish and unresponsive regardless of how high I set the sensitivity. Is there a fix for this?

share|improve this question
    
wow, I thought that was on purpouse -- It makes for a good survival horror mechanic –  Nate Koppenhaver May 15 '12 at 3:40
2  
@NateKoppenhaver Poor gameplay never makes for a good mechanic. –  StrixVaria Jul 29 '12 at 3:30
add comment

1 Answer

up vote 13 down vote accepted

Usually this means that vertical sync is set, and you need to unset it, it's one of the most annoying things ever from computers that are slightly behind recommended specs.

share|improve this answer
3  
Vsync is totally broken in DS1. It works fine is DS2, but hooooly goodness is it awful in DS1. I couldn't even believe I was playing the same game after I disabled it! –  Shinrai Dec 28 '11 at 15:38
6  
That's not entirely correct. This problem is also present on computers which are above the system requirements. I have an Core2Duo with 2.8GHz per Core, 4GiB RAM and a GeForce 9600GT...and with vsync on it's unplayable because the mouse moves so slow. –  Bobby Apr 1 '12 at 19:28
2  
@Bobby, same here. Modern rigs will have trouble until you turn that off. –  Shaderach Jul 5 '12 at 14:32
    
Thanks, this was a nuisance. –  Jack Cole Aug 24 '13 at 9:11
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.