Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I've discovered that my PC ignores the input from my gamepad, a Logitech Rumblepad 2 model #: G-UF13 (corded, not wireless), when I play games with the gamepad in windowed mode. My monitors are currently set to turn off after 10 minutes of inactivity, so at the 10 minute mark, bam, the screens go black, which can be kind of irritating when you're in the middle of a fight.

I'm running Windows 7 64-bit Ultimate Edition SP1. I have the Logitech Profiler software installed, and there are no options in the program concerning power management. I looked up the profile for the controller in my Device Manager under Human Interface Devices searching for the option to let the device wake my PC with no luck either. Am I looking in the wrong place?

no power management options to be found :(

How can I get my PC to recognize my gamepad's input? The problem does not exist in fullscreen mode for games, only windowed. Some of the games I run in windowed mode because either their resolutions are small enough to render my second monitor nigh useless when playing fullscreen or their graphics become stretched, so fullscreen isn't really a comfortable option for me.

share|improve this question
add comment

2 Answers

This solution may solve the problem, along with this MSDN link

In short, in the device manager, you should have some USB Root. Make sure that, in their properties, on the power management tab, the option "Allow the computer to turn of the device to save power" is not activated.

To avoid that windows 7 change the option back, open the Power Option control panel, then, enter the power plan advanced settings. In the USB Settings group, you should activate the "USB Selective Suspend" setting.

share|improve this answer
4  
Welcome to Stack Exchange @PAinstiller! When posting links as an answer, we like users no provide a description of the link, or an excerpt. The reasoning for this is that if the link ever goes dead, the question is still useful. –  Wipqozn Aug 23 '11 at 11:47
add comment

This answer is either wrong or outdated, on Win7 pro x64 with SP1 the device manager setting to let an usb device wake the system from powersaving is greyed out, making it impossible to set it at all.

My solution is to use, an AutoIt, or whatever your desired language is, tool that emulates mouse movement from time to time.

share|improve this answer
    
The option you say is disabled is the exact opposite of the option described in the answer. –  kotekzot Aug 6 '12 at 15:32
    
then i have to correct my text to: The mentioned settings are default in actual win7 environment but aren't working either. ^^ –  user30505 Aug 6 '12 at 15:38
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.