Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm using a laptop with both nVidia and Intel graphics cards. The Intel card is actually fast enough to play Minecraft, and I'd rather not use the nVidia card because it causes the battery life to drop to effectively zero. However, it seems I can't send the game to full screen while using the slower graphics card; it crashes instantly if I do.

How can I get the game to go into fullscreen mode?

share|improve this question
    
Maybe it's not the video card, what are your specs ? Could be a RAM problem or JAVA that's not running well. Have tried updating JAVA ? –  Warface Aug 13 '11 at 1:06
    
@Warface: This is a brand new Windows installation; I just installed the latest Java build. (And fullscreen works just fine if I switch to the nVidia card; I therefore find it hard to believe Java is the issue) –  Billy ONeal Aug 13 '11 at 1:18
    
Can you run other apps fullscreen? –  fredley Aug 13 '11 at 14:35
    
Can you please run Minecraft from the command line and see what error message it outputs? –  Bobby Oct 22 '11 at 16:22
    
@Bobby: I have since given the laptop to my little brother -- I don't have it anymore. –  Billy ONeal Oct 22 '11 at 16:30

2 Answers 2

You probably can't. It probably has to do with indirect rendering . The nvidia card is probably the one writing to the screen, and supports a high resolution. But if you try fullscreen, the intel graphics try to write directly on the screen, which wont work since the nvidia card is doing that, or because it doesn't support such a high resolution. But try lowering resolution, see if that works.

Of course, this is guesswork, as I don't even know what model, drivers, settings, etc, you have.

Suggestion: Go to options -> video settings, select "power saver" mode, and use the nvidia card.

share|improve this answer
    
Don't think that's it - other games and things work, just not Minecraft. –  Billy ONeal Sep 22 '11 at 16:35

What graphics settings are you using? The first thing you should try is reducing your graphics to minimum (fast graphics, tiny render distance, Smooth Lighting off etc.) and seeing if that works. If it does, turn things on until it stops working/goes slow. If it still doesn't run with all graphics set to minimum, you're probably out of luck.

One other thing that's worth checking is Advanced OpenGL - try with it on and off, as it seems to cause problems some of the time when it's on.

share|improve this answer
    
Doesn't matter what settings I choose in the game; it crashes attempting to go to full screen. Maximizing the window works fine. –  Billy ONeal Aug 12 '11 at 23:24

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.