Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I recently purchased Minecraft, but after I have been playing for about 5-10 minutes, the Java process uses all CPU power, leading to a sudden shutdown.

This is weird, because some months ago it ran without any problems.

Is there any way to fix this?

My OS is Ubuntu 11.04.

share|improve this question
1  
What level of graphics are you using? Try turning it down to Fast. –  ChrisF Aug 13 '11 at 15:09
    
Also try reducing every other graphics option to the minimum. –  John the Green Aug 13 '11 at 15:13
1  
    
I have seen this problem on Windows too. In that case it was an old JVM and updating it fixed the problem. Minecraft's stability seems very sensitive to the JVM. On Ubuntu even if your JVM is up-to-date you have two to choose from OpenJDK and Sun's JVM. –  SevenSidedDie Aug 13 '11 at 17:35
    
@Cyclops not a duplicate because the sudden shut down was due to excesive tº of CPU because of the intensive use java was doing of it, and it only happened once –  gumbo Aug 13 '11 at 19:54

4 Answers 4

up vote 7 down vote accepted

I am using Ubuntu too here are a couple of questions and suggestions ...

1) Are you using the open JDK? If you install sun's JDK and run the command sudo update-alternatives --config java and select Sun's JDK.

2) What speed is your processor and how many cores and how much RAM do you have? You might to specficy some command parameters when you run minecraft. Try giving minecraft more RAM by using the -Xmx and -Xms to give Minecraft more RAM at startup. You can read more about that here. For example the command I use is java -Xmx5000m -Xms5000m -jar minecraft.jar

3) Try turning down your video settings. Turn down the render distance and switch the graphics settings to Fast.

share|improve this answer
    
2) is what worked for me, but instead of -Xmx5000m I used java -Xmx1024M -Xms512M -jar minecraft.jar –  gumbo Aug 13 '11 at 19:42
    
@gumbo Yup that will work. I have 6 gigs of RAM so I just set it to some high value so the system doesn't garbage collect chunks. –  Stefan Bossbaly Aug 14 '11 at 1:11

No guys, this is a confirmed bug in Minecraft with Linux. Even on an extremely powerful system using < 400MB of 4 GB of allocated memory, Minecraft will play wonderfully and then suddenly drop to 0 FPS and cause the whole X server to lag. Once closed, everything comes back to normal.

No known fix as of yet.

https://mojang.atlassian.net/browse/MC-2258

share|improve this answer
    
You say it's a "confirmed" bug, but I'm looking at that bug submission in the Mojang bug tracker and it's not confirmed or even accepted by Mojang yet. What definition of "confirmed" are you using? –  SevenSidedDie May 1 '13 at 15:26

I just had this exact problem with a fresh 11.04, setting up the Sun JDK was a doozie, and even then my CPU was spiking over 100% usage, whoa! I could hear the clock in my headphones

Here where my steps to solve it:

  1. Go to synaptic, enable the Canonical Partners repos (the two unchecked boxes)
  2. completely remove the open jdk and jre.
    • You should be prompted to mark the Sun JDK/JRE for install
  3. Install
  4. java -version in a terminal you should get: Java(TM) SE Runtime Environment instead of the OpenJDK
  5. Try to fire up minecraft with java -Xmx1024M -Xms512M -cp minecraft.jar net.minecraft.LauncherFrame
  6. At this point I was noticing the insane CPU usage when adding multiplayer servers (weird). On the main menu in options -> Video Settings change performance to Power Saver

I was stunned that this worked. I remember my old dell laptop had a CPU clock issue where I could hear the high freq in my headphones, the solution was to underclock the processor to get rid of the noise. Pretty cool, it's like underclocking the JVM or telling it to be more sparring with the CPU (which in this case solved made everything run smoothly)

Hope this helps someone

share|improve this answer

I get a similar problem on Windows 7 if I select "Fancy" graphics.

Selecting "Fast" allows me to play for as long as I like.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.