Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Whenever I enter any server on Minecraft, if I press T and write later on I can't send that message to the chat. I've already tried removing /bin folder and letting the game download it again, but that didn't work.

share|improve this question
    
What os are you using? –  Stefan Bossbaly Aug 13 '11 at 20:14
    
My os is Ubuntu 11.04 –  gumbo Aug 13 '11 at 20:55
    
Is the letter T the letter in the controls config for chat? And if you are using the ENTER on the numpad, it'll not work you need to press the "big" ENTER button. –  Warface Aug 13 '11 at 22:02
    
Yes, it's the chat key. I've tried both, but neither worked –  gumbo Aug 13 '11 at 22:43
1  
@gumbo as a test why don't you download the server jar and run it on your local machine and then open minecraft and connect to 'localhost' and see if you can send a message. You will also be able to check the server.log for any errors. –  Stefan Bossbaly Aug 14 '11 at 14:28

3 Answers 3

If the server is running mods, it's possible that new players aren't given the ability to publicly chat until they've "proven" themselves. (Though it does seem odd.) Check the server's web page, if it has one, or try contacting the server admins out-of-game to check whether this is the case.

If you're allowed, you can also post the server's address and port here and I (and probably others) would be happy to report whether we have the same problem on it. :-)

share|improve this answer
    
Thanks, the server direction is server.minasapatridas.com (just paste it). I'll try contacting the mods, though. –  gumbo Aug 14 '11 at 12:54
    
Maybe you could give me a server in which I should be able to write without problems, to test it –  gumbo Aug 14 '11 at 13:34
    
I was indeed able to chat on that server, though there seemed to be significant lag between when I hit Enter and when my message appeared and the Information NPC was very spammy so it was sometimes hard to see what I'd written. I did successfully chat with one of the other players, though, so it was definitely working. Looks like permissions aren't your problem. :-/ –  Ben Blank Aug 14 '11 at 18:14

All you need to do is go to options-Chat settings- and make sure that chat is on "shown"

share|improve this answer

I've had exactly the same problem it was to do with my keyboard mapping in Ubuntu, not with Minecraft itself. Whilst minecraft only accepts "return" to send chat messages for some reason my laptops return key was mapped to "kp_enter" - which meant it functioned correctly for everything else, but not minecraft.

I used this guide on remapping keys and now it works fine.

share|improve this answer
    
A good solution to see if this is necessary would be to try a different USB keyboard, and compare the output xev when you press the keyboard enter and when you press your enter keys. –  Broam Mar 15 '12 at 15:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.