Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I am trying to limit my FPS to 30 for Starcraft 2 on my MacBook Pro (after a while the machine heats up and the FPS drops) - I understand I need to add a few lines to the variables.txt file:

frameratecap=30
frameratecapGlue=30

My problem though is that I cannot find the variables.txt file! A few threads seem to indicate it should be under Users/{username}/Documents/Blizzard/Starcraft II, I found that path (username = shared) but no trace of variables.txt, so I went ahead and created one, but it has no effect on the fps (it is still shooting up to > 100).

Any help appreciated!

share|improve this question

4 Answers 4

up vote 4 down vote accepted

I don't think that's the correct path, I have the following file on my machine:

/Users/username/Library/Application Support/Blizzard/StarCraft II/Variables.txt

I don't see the frame rate variables but there's plenty others, so try adding them there.

share|improve this answer
    
thanks - did the trick! –  JohnIdol Aug 20 '11 at 18:37

They moved the location of the file for Mac installations. I believe it is in the Application Support folder.

share|improve this answer

Have you tried using Vertical Sync? It should be an option under Starcraft II's video settings.

V-Sync matches your monitor's refresh rate/frequency, which prevents your frame rate going higher than your monitor's refresh rate (typically 60 Hz, so you're capped at 60 fps).

While this won't necessarily help you cap it at 30 fps, this may help the overheating problem unless even 60 fps is too high.

share|improve this answer

I noticed you solved your problem, which is fantastic, but I wanted to post this for anybody who might have difficulty in finding this file like I did.

The variables.txt file should be under

/Users/username/Library/Application Support/Blizzard/Starcraft 2/Variables.txt

If you don't see /Users/username/library folder, then it might be hidden. All you have to do is unhide the folder.

Here are some instructions from MikeSel to do that in Lion OS:

  1. Open Finder
  2. Open the Applications/Utilities folder
  3. Open a Terminal
  4. Copy and paste the following line in:

    defaults write com.apple.Finder AppleShowAllFiles YES

  5. Press return
  6. Now hold ‘alt’ on the keyboard and right click on the Finder icon in your dock
  7. Click on "Relaunch"
Now you should see the library folder under your username. Once you are done editing your text file and wish to revert back to hiding the all of those hidden folders and files then perform the steps above; however, replace the terminal command in step 4 with:

defaults write com.apple.Finder AppleShowAllFiles NO

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.