Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

When playing Bastion, the game opens full-screen on a monitor which isn't my primary monitor, unlike any other game. What should I do? I've found a work-around (which I have posted below), but I hope there's a better solution to the problem.

Also notice that although it opens in another monitor, it does use the resolution of the primary monitor.

System is Windows 7 64-bit. I'm launching the game through Steam. This happens both with the full version and the demo version.


Checking the Steam forums, it looks like I'm not the only one with this problem. The makers have responded in this thread:

Q: I have a multi-monitor, Eyefinity, or multi-graphics card setup, and the game is crashing or experiencing issues. What should I do?

A: Please try disabling this type of setup and see if it resolves the issue. We are investigating specific cases for possible updates.

share|improve this question
    
I assume that, in between launches of Bastion on the wrong monitor, you can launch another Steam game and it launches on the proper monitor? –  Shaun Aug 18 '11 at 18:34
    
@Shaun correct, just checked. –  Oak Aug 18 '11 at 21:25
    
Same problem here. Also, dragging to the other monitor crashes the game (probably b/c they are different resolutions.. my 2nd monitor is smaller and just for open windows and other info panes. –  user18160 Jan 12 '12 at 2:00
add comment

4 Answers

up vote 9 down vote accepted

I have this issue too, but for me it's also picking up the resolution of my main monitor and using that, but displaying on the second monitor! I have a 27" 2560x1440 and a 24" 1360x768 monitor. The combination was driving me nuts as I can't even use the menu to do the workaround posted by Oak.

My solution after reading the forum post linked in the question was to add -windowed -noborder to the startup options in Steam, then it runs in fullscreen windowed mode from startup and loads in the correct place on the correct monitor at the correct resolution. It also seems to be the only way to get this particular mode active, which is fine for me as it's my preferred way of playing games.

share|improve this answer
    
Yes, I forgot to mention in the question but in my case as well it used the resolution from my primary monitor. In any case I'm accepting your answer since using -windowed -noborder does indeed lead to the desired results, thank you. –  Oak Aug 24 '11 at 11:42
    
God bless -windowed -noborder. Really. –  Anto Mar 21 '13 at 1:53
add comment

So far I've found a work-around:

  1. In the main menu of Bastion, go to Help & Options -> Display.
  2. Uncheck "Fullscreen".
  3. Drag the window to the correct monitor. The window can be dragged by taking the mouse cursor to the very top of the current monitor (where there is a thin white line), then dragging.
  4. Click the "Fullscreen" option again.

From this point on, the game can be played full-screen on the correct monitor; unfortunately it resets to the incorrect monitor when quitting and running the game again, so this work-around has to be applied every time the game is launched.

share|improve this answer
1  
Do you have Windows 7? Perhaps you could try the window moving shortcut? Shift + WinKey + ArrowKey It moves windows to the screen that's in the direction you press. I think it works for fullscreen applications too. –  Jeff Mercado Aug 18 '11 at 10:00
    
@Jeff nope, doesn't work. –  Oak Aug 18 '11 at 10:02
add comment

There is a solution.

In your steam library (not big picture), right click on Bastion and go to properties. Locate the "Set Launch Options" button.

Click on in and you will see a field open up, type "-windowed" into this field and click accept, or confirm or whatever it says.

The game will now open on a window on the correct monitor. You can full screen it now without the game crashing.

Cheers.

share|improve this answer
1  
This is just repeating the top answer. –  SevenSidedDie Mar 21 '13 at 2:51
add comment

Change your other screen (the one you want to play on) to your primary monitor in either your video cards program or in windows 7's display settings as see if that works.

share|improve this answer
    
The monitor on which I want to play is already my primary monitor. All other games I have ever tried already correctly launch on that monitor. –  Oak Aug 18 '11 at 14:43
    
@Oak on which monitor is the symbolic link to bastion? The same as those games that take the correct monitor? –  Zommuter Aug 18 '11 at 14:58
    
@Tobias I launched the game through Steam. The Steam window was on the primary monitor. –  Oak Aug 18 '11 at 15:07
    
@Oak what happens if you start it while the steam window is on the secondary monitor? maybe the game tries to be "smart" by not blocking the steam window... –  Zommuter Aug 18 '11 at 15:23
    
@Tobias doesn't help... –  Oak Aug 18 '11 at 21:25
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.