Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I've just installed DX:HR via Steam, and I've noticed there's really bad mouse/keyboard lag in the game. Framerate seems fine for the most part, but when I move the mouse, there's about a quarter or half-second delay before my aim moves. It's making the game almost unplayable -- I just had to struggle for a second or two to open a vent because I kept overcorrecting.

Does anybody know why this happens? How can I fix it?

I'm using a wireless keyboard and mouse, but they don't have any noticeable lag when typing or moving the cursor. Even the cursor on the in-game menus doesn't have lag.

share|improve this question
1  
This happened to me - I turned all the graphics settings to minimum and it worked fine, and then I adjusted upwards the more important things (shadows, vsync) until I had settings I was happy with at a speed that was playable. Then I realised I had SLI turned off on my graphics cards so that helped, too! :P –  Samthere Aug 28 '11 at 12:35
    
where do I get to see my screen refresh rate? –  user17334 Dec 29 '11 at 16:17
add comment

6 Answers

Turn V-sync off, usually it's the cause.

share|improve this answer
    
+1, thanks for the great tip. My workstation was fine, but running on my laptop I had to reduce the resolution and lower all settings to the minimum. But... but v-sync was still on. I just turned off v-sync and now I'm able to run at native resolution with some settings above the minimum. –  Feral Chimp Aug 28 '11 at 14:15
add comment

I'm seeing similar issues. Vsync doesn't do a lot for me. Seems to me:

Triple buffering can really tax some systems and make input unresponsive. I assume the game honors the setting you choose, but definitely try turning that off.

There's a negative mouse acceleration (I personally dislike the feel- like a neck brace or eye surgery). Normally this is subtle but under load or with vsync issues can be really bad.

I think I'm also seeing performance hits related to some visibility/caching system they're using (load a level and spin in a circle). Maybe some related to audio, as they seem to do some processing there.

share|improve this answer
add comment

Usually (for me, at least), when this happens, it means that the game is too graphics-intensive for your rig. Try lowering resolution/details, that might fix it, though I can't guarantee that's the issue.

share|improve this answer
add comment

Ok, mouse/kb lag is fixed. Just make sure you have correct refresh rate INGAME, eg if your screen refreshes at 59Hz make sure the game is set to 59 also. My initial setup was defaulted to 24Hz while my LG tv was at 60Hz, hence Fraps was at 24fps. Also turn v-sync off. Hope it helps.

share|improve this answer
add comment

This is odd - I only seem to get lag with the mouse. Using an Xbox 360 controller gives no lag at all, so my choices are to either play on a lower setting with a mouse or use a controller and play on the highest setting my PC can handle.

share|improve this answer
add comment

To whom hasn't solved the problem yet: Microsoft has released a fix that works perfectly: http://support.microsoft.com/kb/2908279

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.