Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I've been poking around in the options menu, trying to find a option for window mode. But, I can't seem to find any.

So, is there any way to get this game running in windowed mode?

share|improve this question
1  
You could try this registry hack which involves removing your user's rights to the key which allegedly controls fullscreen. –  Nick T Aug 31 '11 at 23:52
    
@Nick Too bad it's onyly for DX11 :( –  mordi2k Sep 1 '11 at 1:39

4 Answers 4

up vote 5 down vote accepted

As of the latest patch, windowed mode has been added.

  • Added windowed mode.

Source

share|improve this answer
    
niiiice! I love windowed mode –  z ' Sep 15 '11 at 22:20

No, this does not appear to be possible at the moment.

share|improve this answer

Fullscreen is not supported out of the box but there is a dirty hack:

  1. regedit in cmd

  2. look for folder computer\H_KEY_CURRENT_USER\Software\Eidos\Deus Ex: HR\Graphics

  3. look for fullscren (double click, set value to 0, LEAVE REGEDIT UP)

  4. open explorer to steam>common>deus ex: human revolution folder

  5. Hold left shift while double clicking dxhr.exe

Important Notes

  1. You have to run this in DirectX 11, anything else seems to make it exremely bright for no reason.

  2. Do not alt-tab, ever. ever, EVER, EVER!

  3. You may have to repeat steps 3 to 5 (which is why you leave regedit up)

  4. You will most likely have to keep repeating this process, I saw someone on reddit earlier say it wasn’t working, you just gotta keep at it brosephs

Source

share|improve this answer
    
The method I linked modifies registry key permissions to deny access to change it to the current user, which may be the reason behind leaving regedit open –  Nick T Sep 1 '11 at 18:38
1  
I have to admit that the whole never, ever alt-tab kinda defeats the purpose of windowed mode as well. So sad that the devs didn't support windowed mode on the PC port. –  mordi2k Sep 2 '11 at 2:23

Alt-Enter works - at least with the latest patch.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.