Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I'm playing Portal 2 with my girlfriend, and she gets motion sick. We found out a console option to reduce the field of view, which drastically reduces her sickness (cl_fov_75). However, this option is not persisted, so if we forget to input the command she'll get sick again. Is there any command in the Portal 2 console to make this persistant (either with another command, or by modifying some kind of ini file)?

share|improve this question
    
related: How can I prevent Gaming Sickness? –  Zommuter Feb 20 '12 at 7:13
add comment

3 Answers

up vote 10 down vote accepted

It's not recommended to modify config.cfg, since it can easily be overwritten by the game. The proper file to write your scripts and commands is autoexec.cfg which should be located in the same folder ([steam location]\steamapps\common\portal 2\portal2\cfg). If it's not there - create it. This file is executed automaticly when you load a map.

cl_fov 75;

should solve your problem.

share|improve this answer
1  
Ahh yes, this is actually the file I was looking for (since all other Valve games use it, I use it over excessively in TF2 and CSS) but I forgot that you can create it if it's not there. –  Mr Smooth Sep 2 '11 at 4:36
1  
Unfortunately we tried and this doesn't seem to work, fov is 90 as usual... we tried all kinds of combinations (changing fov_desired, using "75" instead of 75, modifying config.cfg (which gets overwritten with the default values each time we execute the game) and nothing seems to work, just the manual override. –  Sirs Sep 3 '11 at 12:41
    
I've tryed it before posting here and I know it works. Did you try to execute your config manualy by typing "exec autoexec" in console? Does it help? Does "autoexec" appear in drop-down list there? –  Air Sep 3 '11 at 19:29
add comment

In your Steam folder for the game, there's a folder inside the "portal2" folder called "cfg" (I think the default C:\Program Files\Steam[usernamehere]\Portal 2\portal2\cfg) inside that folder there's a file called "config.cfg".

In that file there's a line called fov_desired "90.000000"

Changing that to 75 might work.

If not, then adding "cl_fov_75" as another line at the end should.

share|improve this answer
add comment

Don't know if you've already sorted this, but.. I own Portal 2 on 360 rather than PC, but I looked around anyway. I read that Portal has problems with actually using autoexec.cfg files, but it appears that setting custom launch options might work.

Right-click Portal 2 in Steam > Click 'Properties' > Click 'Set launch options'. In this you can put your cvar as a launch option, so (including the dash) put in -cl_fov 75.

Hopefully that actually sets the cvar for you.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.