Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I can't stand screen tearing and I'm wondering how I can turn on vertical sync. There doesn't seem to be on option to turn it on through the game itself. Where can I find the file to turn it on? Are there other settings I can adjust that aren't available ingame? I'm running Windows 7.

share|improve this question

4 Answers 4

You can also download RivaTuner and use D3DOverrider (which comes with it) to fix screen tearing in game.

share|improve this answer
up vote 10 down vote accepted

Use Dead Island Helper

If you do not feel comfortable editing files by hand, you can use Dead Island Helper, a program which will do this for you. According to the creator, it does install a keyboard hook to detect if Dead Island is running, but only to prevent multiple keystrokes from being processed. It shouldn't trigger VAC, but you have to decide for yourself if you want to run the risk.

If you'd rather edit files yourself, you can follow the steps outlined below:

Turning on VSync

  • Navigate to My Documents\Dead Island\out\Settings

Here, you'll find a files named Video.scr Windows 7 will recognize this file as a screensaver file, so you need to open it with a file editor such as Notepad. You can do this by dragging and dropping the Video.scr file to Notepad or using Notepad and navigating to the directory. Remember to change the dropdown to look for "All files" if you do this.

Upon opening the file, you will find something that looks like this:

!Resolution(i,i)
!WindowOffset(i,i)
!Monitor(i) // -1 primary monitor
!BPP(i)
!FSAA(i) // Full Screen AntiAliasing, 0 - none, higher is better
!TexBPP(i)
!TextureQuality(s) // VeryLow, Low, High
!Filtering(s) // Bilinear, Trilinear, Anisotropic, AnisotropicTrilinear
!GammaFloat(f)
!MaxRefresh(i)
!Shadows(s) // Low, High
!ShadowMapSize(i)
!SpotShadowMapSize(i)
!Lightmaps()
!Fullscreen()
!VSync() // enable vertical sync
!MaterialQuality(i) // lower is better
!WaterQuality(i) // lower is better
!GrassQuality(i) // lower is better
!FXQuality(i) // higher is better
!FXFadeLevel(i) // 0-4 (lower is better)
!EnvQuality(s) // FullDynamic, RareDynamic, Static
!ShaderPath(i) // 0 - 1.1, 1 - 1.4, 2 - 2.0, 3 - 3.0, 4 - x360, 5 - 4.0, 6 - ps3
!PostProcess(s) // Simple, Normal
!DisplayDeviceType(i,f,f,f,f) //device type (LCD TV etc.): 0 - default
!Curves(s) // curves texure

Resolution(1920,1080)
Monitor(0)
BPP(24)
FSAA(0)
TexBPP(32)
TextureQuality("High")
Filtering("Trilinear")
Fullscreen()
Shadows("High")
ShadowMapSize(1024)
SpotShadowMapSize(1024)
Lightmaps()
GammaFloat(1.00)
MaxRefresh(60)
MaterialQuality(2)
FXQuality(3)
FXFadeLevel(2)
WaterQuality(2)
GrassQuality(0)
EnvQuality("FullDynamic")
ShaderPath(3)
DisplayDeviceType(0,0.000000,1.000000,1.000000,1.0 00000) 

These are the default values that the game is using. If you want to enable Vertical Sync, insert VSync() between the values of Fullscreen() and Shadows("High") like so:

Fullscreen()
VSync()
Shadows("High")

Remember that if you want this to work properly, you need to have refresh rate set to the same value as your monitor's refresh rate. That variable is:

MaxRefresh(60)

After making this adjustment, click Save and exit. It is currently under dispute whether or not you need to set this file as Read-only or not, as some people say that you need to, otherwise the game will overwrite your settings and others say that it will only overwrite invalid settings. I did not need to until I changed my Post Processing settings, which didn't seem to take until I set it as Read-only. If you want to play it safe, you can set it by doing the following:

  • Rightclick the Video.scr file
  • Select Properties
  • On the General tab you'll see Attributes near the bottom
  • Check Read-only box and click Apply then OK

Increasing the graphical quality

Even after setting the ingame options to "High," there's still more you can do to increase the graphical quality. You can adjust other attributes in this file if you are comfortable doing so and know what your video card and system can handle.

If you choose to adjust these individual settings, I would advise only changing one variable at a time so you know what to change back in case of crashing (if you have it set as "Read-only" at least, theoretically it should change any invalid values automatically if it doesn't).

Increase color quality

BPP(24)

Change this setting to 32. And in conjunction with this make sure you:

Enable Post Processing

PostProcess("Normal")

Add this line, it doesn't seem to matter where you put it.

Enable FSAA (Fullscreen Anti-Aliasing)

FSAA(0)

Change the 0 to either 2,4, 8, or 16.

Increase environmental detail settings

MaterialQuality(2)
FXFadeLevel(2)
WaterQuality(2)
GrassQuality(0)

Make sure all of these are set to 0.

Increase the texture quality

Filtering("Trilinear")

Change Trilinear to Anisotropic or AnisotropicTrilinear.

Increase shadow quality

ShadowMapSize(1024)
SpotShadowMapSize(1024)

Change 1024 to either 2048 or 4096. Note that changing these settings may cause crashing. I was succesfully able to change SpotShadowMapSize to 4096, however I could only increase ShadowMapSize to 2048 without crashing. As stated, make sure you change variables individually to be able to pinpoint crash causes.

Example setup

I'm running an ATi Radeon HD 4890 1GB card on a system with 12GB RAM and my settings are as follows:

Resolution(1920,1080)
Monitor(0)
BPP(32)
FSAA(16)
TexBPP(32)
TextureQuality("High")
Filtering("AnisotropicTrilinear")
Fullscreen()
Shadows("High")
ShadowMapSize(2048)
SpotShadowMapSize(4096)
Lightmaps()
GammaFloat(1.35)
MaxRefresh(60)
MaterialQuality(0)
FXQuality(3)
FXFadeLevel(0)
WaterQuality(0)
GrassQuality(0)
EnvQuality("FullDynamic")
ShaderPath(5)
VSync()
PostProcess("Normal")
DisplayDeviceType(0,0.000000,1.000000,1.000000,1.000000)

~Sources: This thread and this thread on the Steam forums

share|improve this answer

A video guide going step by step with some of the same information for those that take in information easier by watching instead of reading.

share|improve this answer

There is a simple workaround to enable VSync in Dead Island.

  • Navigate to "Documents\DeadIsland\out\Settings"
  • Find and open the file "video" with in a text editor like notepad.
  • Find the line where "Fullscreen()" is written.
  • Add "VSync()" on a new line under "Fullscreen()"

Note: If this do not work, you might have to edit permissions on the file to read-only, since the game can edit the file to change what you added.

  • Right click the file and click "option"s
  • Mark the box called "Read-only" under the "Attributes" tag.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.