Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Someone gave me this game as a birthday present. Unfortunataly the installation does not even start under Windows 7, Compability Mode does not help with that. It is a Windows 95 game. How can I get it up and running again.

share|improve this question
add comment

2 Answers

The installation for Frogger 2 is likely a 16-bit application, which are not supported on 64-bit versions of Windows.

Unfortunately, this only leaves you two options: Find if someone has written a 32-bit or 64-bit installer (this has happened for Grim Fandango and a few other games) or use a Virtual Machine.

Having said that, Virtual Box's Direct3D support was limited to DirectX 8 and 9. Unfortunately, this means that older titles do not work on it.

VMWare Player appears to support DX7 and earlier, but it has a somewhat intrusive signup process even though it's a free app, which involves them annoyingly sending you an email newsletter.

share|improve this answer
add comment
up vote 1 down vote accepted

I finally figured this out. Compability Mode will not help even if one gets the game installed it still crashes. Windows 95 Virtual machines also seem problematic. Instead do this:

  1. Install Virtual Box Install Windows XP (I used Service Pack 3)

  2. Install Guest Addition and Select Direct3D-Support

  3. Change Display Options of your Virtual Machine Give it some graphic memory (I used 64 less should also work)
  4. Activate 3D and 2D Video acceleration

Now when starting the Virtual Machine

  1. Reduce the Color Depth to 16 Bit (32 Bit leads to distorted colors)
  2. Set resolution to 1024*768
  3. Install Frogger 2 with the CD (Restart is not necessary)

Everytime you want to play the game

  1. Start it with 1024*768 resolution, software rendering, do not tick windowed mode:

    This will lead to the following error message: Frogger2 failed to start DirectX. You could try the following: Run in full-screen mode (uncheck Run Windowed) Select a lower video resolution Use the software rendering mode If these do not help, consult the accompanying documentation.

  2. Click OK

  3. Now use the keyboard (If it works for you you can also use the mouse, but for me the mouse behaves weird above the settings window) to tick the box Run Windowed and start the game with Enter.

It will run windowed but look as if it is running in full screen mode. Have fun! :D

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.