Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I decided to try out Dead Island's co-op mode. Unfortunately, there seems to be no way to turn off voicechat and I can't find any push to talk option. I don't want to just unplug my microphone because I want to be able to chat with my friends using Mumble or some other external program.

I can't seem to find any option in the audio configuration file to turn off voicechat or change it to push to talk. Is there any way to do this or do I need to wait for a patch?

share|improve this question
    
There doesn't seem to be one atm, it's the same for the new warhammer 40k as well...I'm sure someone has experience with disabling the microphone for specific programs though :D –  Domocus Sep 11 '11 at 17:27
    
Just to clarify, do you just want the microphone off? –  mordi2k Sep 11 '11 at 19:19
    
@mordi I'd accept either a push to talk solution or a way to disable it entirely ingame without completely disabling my microphone out of game. I edited my question to clarify. –  FAE Sep 11 '11 at 20:09
    
@Fallen there are no options to click-to-speak or even to mute annoying. Reason being, since its an XB360 port to PC game, they didn't take into account that PC users don't all have easily accessible mute switches for our mic. –  Mechaflash Sep 14 '11 at 16:29
    
In-game voice chat works at least as good (if not better) than any other external program. Just turn off the damn external program and play. –  user12547 Sep 17 '11 at 23:48
show 1 more comment

3 Answers

up vote 3 down vote accepted

As of the latest Dead Island patch, there is now a way to disable voice chat in the options:

enter image description here

share|improve this answer
add comment

The only way to do it as far as I know is to change the default Windows microphone in your audio settings. If you change it to something that isn't really a microphone like "Line In," then it is effectively turned off in Dead Island. This doesn't really affect other "real" voice applications (Skype/Mumble/etc) as you can just manually set the microphone in each of those. While it isn't in game, it is currently the one and only solution.

share|improve this answer
    
I changed my default to "Line In" but my friend still heard me ingame. :/ –  FAE Oct 7 '11 at 13:03
    
That is odd. I did it as well as the other two guys I played with. It worked for all three of us. Perhaps try another non-microphone? And maybe try restarting Dead Island after. –  Morinar Oct 10 '11 at 15:41
add comment

For those running an older version that doesn't have the voice chat toggle, you may follow these steps to turn off voice chat:

Note: turn Dead Island off before doing this.

  1. Go to the sound options for your computer. (In Windows 7, this is Control Panel -> Sound)
  2. Select the Recording tab.
  3. Find an unused input device, such as Line-In or Stereo Mix.
  4. Right click -> set as default.
  5. Right click -> set as default communications device.
  6. Double click, switch to Levels tab, set volume to 0.
  7. Start Dead Island.

Alternatively, if you have a USB device as your audio input, unplug it, start Dead Island, then plug it back in.

Please also note that if you are using an external voice chat client such as Ventrilo, Mumble, or TeamSpeak, you will want to set up the respective client to use your actual voice input instead of the default.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.