Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

So my 13 year old son is a Minecraft player, and I've been trying to get the new version up and running for him.

Howerver, neither the 1.8 PR 1 nor the PR 2 version seems to work.

He's been running a 1.7.3 server without problems, but I can't seem to get the 1.8 stuff working.

The server is running on my linux box, which has the appropriate port-forwarding set up. This has been working for a while with the 1.7.3 server, and it seems like 1/2 the kids in the neighborhood are connecting to it, so I'm assuming it's not the problem.

Anyways, I created a new directory on the server, dropped in the 1.8 minecraft_server.jar, and started it up - it seems to start up OK, but I can't connect to it.

For the client machine, I've tried both XP and Win7 machines, and Chrome, FF and even IE - the results are the same: I log in, click on "in browser" which takes me to www.mindcraft.net/game, I get a brief flash of "updating", then a black box for a while and then finally a white box.

On the client machine, I tried deleting the entire .mindcraft directory from %AppData%, then just replacing the mindcraft.jar in the bin/ directory, and I also tried modifying the jar to remove the META-INF/ directory from the jar - nothing seems to make any difference, and I can't find any information on how to do any debugging to see what's going on.

So is it possible to enable debugging in the browser to see where the problems is? Is this a known issue, and is there a work around?

share|improve this question

migrated from superuser.com Sep 14 '11 at 11:26

This question came from our site for computer enthusiasts and power users.

closed as too localized by Mark Trapp, StrixVaria, fredley, lunboks, Raven Dreamer Sep 14 '11 at 18:25

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

Minecraft 1.8 final just came out and you should catch it via auto-update like every other update: this question seems entirely obsolete now. –  user3389 Sep 14 '11 at 12:30
From what I can tell, that's the pre-release - the one I'm trying to get working. –  chris Sep 14 '11 at 13:39
@chris Nope, the "official" 1.8 (not prerelease) has been released. Update the client through the launcher as usual, and download the server jar. (Note though that you can't run 1.7 and 1.8 servers on the same machine: they use the same port, so only the first one started can even see incoming client connections.) –  SevenSidedDie Sep 14 '11 at 14:27
This question is no longer relevant, since 1.8 has now been released via official channels. –  fredley Sep 14 '11 at 16:19

1 Answer 1

Just reinstall and download the 1.8 Patch that has just been uploaded.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.