Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

After having tried the 1.8 prerelease, I wanted the 1.8 final of course, but I couldn't log in through the launcher (and hence, could not get the update through the launcher like normal). I just got some error message and an invitation to play offline. Somebody suggested to re-download the launcher so I did, from I moved the new to Applications, overwriting the old (stupid). Now nothing happens when I double click - the icon "expands" in that little "swoosh" animation that happens every time you open something on a mac, but after that, nothing happens, no window, no error message, nothing.

I tried renaming the 1.8 pre-release minecraft.jar file - that changed nothing.
I tried renaming the entire minecraft folder in Application Support - that also changed nothing.
Numerous restarts, what have you - no change.
I even tried to find the latest Java JRE for mac through - that was fun... and futile (since Apple makes their own stupid version of Java, and Oracle just happily ignores the existence of OSX).

Everything is updated just fine (according to Software Update), with the exception of me not having upgraded to Lion yet, which I hope (and sort of insist) is not the cause.

Am I alone in this? Any suggestions? Do I need to migrate my game and saves to my Windows machine? (that would kind of suck, as it does).

share|improve this question
Weird, opening the package contents of and finding MinecraftLauncher.jar and double clicking on that does open the launcher, I can log in - and it downloaded the required files the first time - then it hangs for a long time on the MOJANG logo but eventually I get to the game and it seems to run fine. But still when I run the package - - nothing happens. I have to run the MinecraftLauncher.jar from inside the package. Weird :( – gakera Sep 18 '11 at 0:24
Le-sigh, it runs for a few minutes but then runs out of memory and soft-crashes (warns me, saves and tells me to restart the game) – gakera Sep 18 '11 at 0:44
Untill I can post my own answer (silly, but necessary, stackexchange rules), the solution is found here: – gakera Sep 18 '11 at 1:50
OMG the exact same thing is happening to me – user13374 Oct 23 '11 at 22:34
@John try the solution below, it has worked for me on a couple of different occasions (when I was downloading a new version, when I was trying to mod minecraft etc..) – gakera Nov 8 '11 at 13:43
up vote 5 down vote accepted

I found the answer on the minecraft forums, so I'll repost it here. Thanks to

ahefner said: The bundle doesn't work because some unix file permissions get screwed up as a result of distributing the app bundle inside a zip file (versus, say, a .dmg). You can fix it from the terminal using the chmod command as follows:

chmod +x ~/Downloads/

Modify the above command to reflect where you unzipped Minecraft at. This will fix the bundle so that it opens when you click it.

share|improve this answer

Play it from browser, if that doesn't work, delete and download again.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.