Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

In preparation of the upcoming Battlefield 3 Open Beta, today I attempted to set up Origin to install to the proper directories.

My base Origin is installed at:

"E:\Games\Origin".

For some reason though, Origin wants to install all of my games to:

"C:\Program Files (x86)\Origin Games\".

So I attempted to change this to:

"E:\Games\Origin\Games", or even just "E:\Games",

however I keep getting the error message: "The game installation directory is invalid. Please select a different directory." This always comes up unless I pick a directory that is in "C:\Program Files (x86)\" somewhere.

As you can see below: Red is the error message I get every time I try to change the directory, Green is the default location which can only be changed to VERY similar locations, and Blue is showing the fact that I can change the location of the installers just fine.

My Problem

Is there any way (even using other programs, like a registry editor) to change the directory that Origin will install my games to?

share|improve this question

3 Answers 3

up vote 22 down vote accepted

Edit, October 2013: This solution is now outdated; though, with the new filename still valid. Changing the directory from within the client's settings should work without a problem. See http://gaming.stackexchange.com/a/129935/23 for a detailed walkthrough.

Locate the "Origin" sub-folder in your Application Data - or simply use Start | Run | "%AppData%\Origin".

There's a local.xml file, open it with a text editor and change the path in the line that begins with

<Setting key="DownloadInPlaceDir"
share|improve this answer
    
This seems to have worked, but I still get the same error message every time I open settings, although I don't really care about that, so if this works when I install Battlefield I'll accept this answer –  Mr Smooth Oct 20 '11 at 4:06
    
This worked like a charm. Like I said before though, I still get the error when I open settings, but it doesn't stop things from installing there, just a little annoying. Not that big of a deal though, hardly ever open settings, and when I do it's just one click and it's gone. Thanks a bunch. –  Mr Smooth Oct 26 '11 at 6:12
1  
Addendum: Since one of the last updates, you get a message about an invalid directory every time you open the Settings dialogue. It'll only go away when you reset the directory to standard or force-quit the application. As long as you do not open the Settings, it seems to work fine, though. –  jello Nov 12 '11 at 16:36
    
What jello says is true. Luckily, in the same file that you can change your install directory, you can also change all the other settings, so you don't need to use settings at all. –  Mr Smooth Nov 12 '11 at 17:03
    
I managed to achieve something similar by updating the XML file, and then reloading Origin. It said my games were not installed so I clicked install and 2-3 minutes later, it was done. I assume it was checking the games already in the folder. –  DavidYell Feb 9 '12 at 10:18

The accepted answer is now totally incorrect as of late 2013. That XML file doesn't even exist any more.

The good news is that the Origin app does (finally?) support properly remapping the download and install folders, as seen in the Origin | Application Settings | Advanced menu.

origin, application settings, advanced

Here I changed mine to d:\Origin so it would be on my larger storage drive, not my small boot SSD:

advanced path settings

I cleared out all my old Origin games and started downloading Dead Space 3, which I got through some Humble Bundle recently, and I see that the files are indeed going to the d:\Origin\ folder I manually specified in the Origin settings..

enter image description here

In this case it's downloading directly to the game folder, not the "game installers" path but it is respecting my choice of folder and not forcing it to the c:\ drive.

share|improve this answer

It's a little bit of a workaround, not a fix, but you could trick Origin in to thinking you've not changed anything, while putting the data wherever you want by making using of a directory junction point.

Please note that I don't have Origin and haven't tested this with Origin, but it's a trick I use all the time - Windows User Profile, Steam, Music, and so on...

Also note that my instructions here require Windows 7 or Windows Vista. You can do this on Win XP, but I cannot remember what the command is...

  1. Close Origin and all games.

  2. Copy the current folder to the desired location. You must ensure there is no longer a folder with the old name on the system as we're going to place something of that name in a moment.
    For sake of safety I recommend you copy the data to the final location (not move) and then simply rename the old location, deleting it only after you know everything is working.

  3. Run a copy of the command prompt as an administrator: find command prompt on the start menu, right-click, and choose "run as administrator"

  4. Run the following command (with the relevant old and new locations, in that order):
    mklink /D "C:\Program Files (x86)\Origin Games\" "D:\Games\Origin\Games"

This will create a directory junction point (essentially a symbolic link) in the old location that will silently redirect all requests to use that location (and any sub-locations) to the new location you have specified, it does this without the knowledge of most programs - so they will continue to work unaffected.

I personally used this months ago to move all 100GB or so of installed Steam games to a completely different hard drive, it has worked perfectly since then because Steam still thinks it is installed in the same place as it was before.

share|improve this answer
    
I don't have any games installed in Origin at the moment, so I can't tell you if it's working or not (the BF3 beta has been uninstalled), but once I get Battlefield 3 (the 27th) I'll test it and if it works I will accept this answer. –  Mr Smooth Oct 19 '11 at 15:55
    
if, as mentioned here, E:\Program Files (x86) works, with WinXP good old subst might do the trick –  Zommuter Oct 24 '11 at 6:12

protected by Mana Nov 5 '11 at 15:25

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.