Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

This is driving me insane...I have been playing Minecraft for over a year on a different computer and now I'm playing it on my normal computer... anyway the issue is that when I hold down any key for too long on Minecraft doesn't register the key release.

For example if I hold w for ~2 seconds I'll keep going in that direction... same with spacebar etc...

I checked if the keys are getting stuck on my board and they are not....

Anyone have ideas? It's annoying as hell.

share|improve this question
4  
Have you tried pressing the key a few times? If you keep pressing the key and your keyboard isn't actually stuck, eventually the keyRelease event should trigger. –  Raven Dreamer Oct 6 '11 at 5:37
    
@Raven that doesn't actually keep the initial problem from happening though. –  DwarfSlice Oct 6 '11 at 5:59
4  
Which OS are you running? –  mordi2k Oct 6 '11 at 7:25
3  
Have you tried with a different keyboard? –  fredley Oct 6 '11 at 13:16
1  
possible duplicate of Why does my character walk forward automatically? (linux, but still likely related) –  Zommuter Nov 12 '11 at 13:32

4 Answers 4

Check your keystroke repeat rate/repeat delay and turn it down if you have to. I used to run into the same thing back in the day when playing Unreal Tournament and it turned out that the keystroke repeat was kicking in and that was what was keeping me running in the same direction even though I would have different keys held down.

XP & Win7 both: Start > Control Panel > Keyboard

share|improve this answer
    
Nope not it. :( Think I may reformat my computer tomorrow and see if that fixes it. –  josipii Oct 6 '11 at 15:28
    
@josipii That's a bit extreme. I'd highly recommend finding another keyboard and trying with that first. –  fredley Oct 6 '11 at 16:05
    
I did. Same issue. No big deal...been meaning to reformat for the past 9 months haha. So much bloatware all over my computer. –  josipii Oct 6 '11 at 16:12

You need to update LWJGL. Hit the link for details on how to update it(the bash script worked nicely for me)

http://www.minecraftwiki.net/wiki/Tutorials/Update_LWJGL

share|improve this answer

This sometimes happens to me on my older computer (running Ubuntu) I don't have a problem on a more powerful Pc with Vista. It seemed to happen a lot when I had other processes running like the update manager. I would suggest making sure no other background processes are running and perhaps your PC is not powerful enough to keep up. Since the lighting model changed in 1.8 I have had this problem less - it was especially bad when day turned to night or vice versa and when it was raining!

share|improve this answer

It happened to me a few times

In singleplayer: hit esc, then back to game.

In multiplayer: disconnect, then reconnect.

If that still does not work, check the delays between key strokes.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.