Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

While playing Braid, I constantly see sprites flickering and disappearing through the whole game. I have searched a lot but no one seems to have the same problem on PC or Console.

here are some example screenshots:
weird artifacts more weird stuff disappearing stuff

here is the full album of woe

I bought Braid as part of Humble Bundle 3 and activated it on Steam.

It is running on XP Professional with 2.00 GHz processor and 1.37 GB of RAM video card Nvidia GeForce 6100

Thanks in advance.

share|improve this question
2  
I don't have a specific answer for you, but you should try manually updating Direct X and your graphics card drivers. If that doesn't help, updating your .net, c++, and visual basic redistributable packages might do the trick (I'm not sure which, if any, of those three Braid uses). –  Fambida Oct 7 '11 at 22:28
    
@Fambida I don't have a .net framework installed, and it seems that Braid's programmer might use C++. Sorry i'm dumb how would you manually update DirectX a redistributable package? –  RedRiderX Oct 8 '11 at 13:21
    
To update Direct X for XP use this. To update your c++ use this –  Fambida Oct 8 '11 at 20:50
    
Steam should actually take care of all required DirectX, .net, vlc and whatnot files. Too much sometimes... –  Zommuter Oct 9 '11 at 11:38
    
I only play Braid through Steam which i keep up to date. does that mean i don't need to manually update my redistributable packages? –  RedRiderX Oct 9 '11 at 19:38
add comment

3 Answers

up vote 1 down vote accepted

I had that flickering, too. Turning VSync off did the trick for me: In Steam, right click Braid, choose properties, then Set Launch Options... and enter -no_vsync there. You can also try -windowed or -30fps. There's a list of Braid's command line switches with which you could further play around.

If you're not running Braid via Steam, first, as Fambida suggested, make sure you got the required DirectX files etc. Then right click your Braid shortcut, choose properties and append -no_vsync after Braid.exe (if there are quotes, after these).

share|improve this answer
    
'-no_vsync' had no apparent effect for me. Neither did '-30fps', '-half', '-windowed' or '-no_post', sorry. –  RedRiderX Oct 9 '11 at 19:45
1  
Sorry to hear that. Is this the only game where you are experiencing graphic glitches? Did you, as Fambida and TrewTzu suggested, update your graphics card drivers? That's the only thing Steam does not automatically install, though it should give you a warning if it detects outdated drivers (unless one ticks the don't remind me again box) –  Zommuter Oct 9 '11 at 20:06
    
No, i have not updated my graphics card driver, but this is the only game that has had problems. how would i manually update my Nvida graphics card drivers? –  RedRiderX Oct 10 '11 at 11:40
1  
@RedriderX: I think Steam has a Check for graphics driver updates... item in its main menu taking you to nvidia.com/Download/index.aspx. Also, is it a Desktop PC or a notebook? –  Zommuter Oct 10 '11 at 12:04
1  
I updated my graphics card drivers and all the flickering went away, thanks . –  RedRiderX Oct 11 '11 at 11:45
add comment

All I can suggest is updating your Graphics card and C++ redistributable package like Fambida suggested above, and then try running as administrator.

share|improve this answer
    
I have added my video card onto the question. –  RedRiderX Oct 9 '11 at 11:47
add comment

I had the whole game screen flashing in fullscreen mode. I fixed it by right click>properties braid in steam, and "set startup options to -no_vsync this fixed it for me.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.