Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I just installed the full version of Might and Magic Heroes VI, and whether I'm in the menus or playing the game, my cursor is blinking constantly. I've tried tinkering with all the graphics settings, but I can't make it stop. I didn't have this problem with the demo. Is there anything I can do?

share|improve this question
    
Have you tried reinstalling it? –  Wipqozn Oct 14 '11 at 1:30
1  
@wipq Ugh, no, then I'd have to download it from Steam all over again. –  bwarner Oct 14 '11 at 2:27
    
I've had this problem, too. I turned on V-Sync and it seemed to help quite a bit (but not completely.) Did you try this, and did it help? –  dlras2 Oct 14 '11 at 3:08
    
Another possible solution would be to play in a window. –  Pubby Oct 14 '11 at 3:09
    
@Pubby8 - I get the same experience even in window'd mode. –  Raven Dreamer Oct 14 '11 at 3:26

5 Answers 5

up vote 5 down vote accepted

As of Ubisoft's 1.1.1 patch, this issue should be fixed!

• Hot fix on default setting video option detection at start-up causing possible dead locks on laptops

• Blinking cursor fix

• Fixing a version number issue

share|improve this answer
    
Still happening for me, hopefully that means that the patch just hasn't dropped yet, since I assume UPlay automatically applies it. –  bwarner Oct 19 '11 at 13:28
    
@bwarner if you have steam, steam will automatically download it (it did for me, and it solved the problem). If you don't have a steam version, I dunno how you get the patch. –  Raven Dreamer Oct 19 '11 at 13:44
    
Ah, I just remembered that I have Steam in offline mode right now, that probably explains it. –  bwarner Oct 19 '11 at 14:05

This is currently an ongoing issue for a lot of players, Ubisoft is working on a no-ETA patch to fix this bug. So wait patiently till they manage to get it out.

Strangely I am one of the few people who do not have this issue.

share|improve this answer
    
It seems to happen intermittently. –  Raven Dreamer Oct 14 '11 at 17:11

Solution is to limit your FPS to 59 or lower. It seems to blink only with 60 FPS. People who own older machines and can't reach max FPS or don't have constant 60 FPS are not experiencing this bug.

share|improve this answer
3  
How do I limit FPS? Do I need to use a graphics card utility? –  bwarner Oct 16 '11 at 2:48
    
How did they not catch this before the release!? –  BlueRaja - Danny Pflughoeft Jan 25 '12 at 0:11

The solution for blinking cursor problem (for me it worked): right click on the desktop icon of Heroes 6 and click properties, then go to the compatibility tab, then tick the third and the fourth check boxes in "Settings" ("Disable visual themes" and "Disable desktop composition")

share|improve this answer

The solution to a flickering cursor is the same for many Ubisoft games. I dont know why, but many Ubisoft games ran better when I set my CPU affinity lower. Setting my affinity to 2 instead of 4 cores stopped flickering and other issues. This fix worked in many other games (like Splinter Cell etc.).

share|improve this answer
    
How did this add to the other answers? In addition, I believe that the games should run better when you set the affinity higher to give it more processing power. –  Jeffrey Lin Oct 21 '12 at 19:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.