Take the 2-minute tour ×
Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

I got Battlefield Bad Company 2 last night on Steam and I was trying to play online, but I get disconnected within 5 minutes of joining and usually get an error saying: "You have lost connection to the EA server".

I have read that BFBC2 uses port forwarding so I went to www.portforward.com and there was a guide to set it up for my DLink router, however I still get disconnected. I don't believe its an issue with my internet because I have played other online games fine on it, and can download things such as movies with sufficient speed.

I am going to give it another try this evening, but I was wondering if anyone else who came across this problem possibly had other suggestion on what I could do to possibly fix this?

Edit: I tried updated my punkbuster as well as playing server without punkbuster along with other troubleshooting steps but the disconnection continued, I then contacted ea and they got me to run a program that traces packets, and they told me the problem is with my internet service provider and that I am losing packets.

share|improve this question
    
Punkbuster comes to mind. Try connecting to servers which have PB turned off and see if you disconnect. –  DrFish Oct 18 '11 at 15:00
    
Boras comment is a good shout Battlefield games have always been plagued by Punkbuster problems, if you can indeed play a non-punkbuster game and not get kicked head over to evenbalance.com/index.php and grab the latest BFBC2 files and update it manually :) –  Craig Pilgrim Oct 19 '11 at 9:24
    
@Beef: Since you have a solution, you should put that as an answer to your own question and, later on, accept it. –  DrFish Oct 19 '11 at 13:31
    
Did you try it again? I have had problems in the past with some EA games (servers seem to be down a little too often), but they were up later. –  SSumner Oct 21 '11 at 19:49
    
I try everyone once and a while, my IPS told me my internet speed would increase significantly when its fixed which it has, but I still get disconnected and lose packets, havnt tried since Friday though plan to try again tonight –  Beef Oct 24 '11 at 12:49

1 Answer 1

up vote 0 down vote accepted

I contacted ea and they got me to run a program that traces packets, and they told me the problem is with my internet service provider and that I am losing packets. If anyone else comes across this problem I first recommend the punkbuster solution, then doing the port forwarding and if all else fails contact ea, and it may be the same as my issue. Its rogers internet but its through techsavy

share|improve this answer
    
Thats strange the game will usually display an error message along the lines of 'losing key packets' if that was the case. Either way im glad you have an answer, might be an idea to include the name of your ISP in the answer so that people know who it is you had problems with. –  Craig Pilgrim Oct 19 '11 at 15:49

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.