Arqade is a question and answer site for passionate videogamers on all platforms. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

In game, instead of hats (any other than default) a big 3D red "ERROR" is displayed. It used to work well till the update (the one when everyone got that paper boat hat). After loading a character's hat (in menu or in game no difference), the game would crash, and after few more updates I'm stuck with the "ERROR hat".

Anyone else got this, are there any fixes or updates planned?

NOTE: I didn't use any mods, touch Steam files or other things that would result in missing data.


share|improve this question
Have you had Steam verify the file integrity for your TF2 install? – DMA57361 Oct 21 '11 at 14:07
Didn't know about that,i tried it now but it's still the same.Reinstalling the game completly should work but it is the last option...btw what does "defragment cache" on stem do? is it worth running? – Arremer Oct 21 '11 at 16:43
checking file integrity is effectively the same as a reinstall (except you keep your settings) - any file that isn't "right" would have been automatically re-downloaded. Defrag'ing the cache will simply defrag all the games downloaded files, only useful if they're heavily fragmented, but otherwise no effect. – DMA57361 Oct 21 '11 at 16:49
If you have the developer console enabled, what errors are appearing in it? You can enable it via Options -> Advanced -> Enable Developer Console, then press the key left of 1 on the kwyboard (` or ~ for US 104/105) to open it. – user2974 Oct 21 '11 at 17:20
@DMA57361: I'm doing this just to ping you so you can see Arremer's comment right before mine. – user2974 Oct 21 '11 at 19:43
up vote 2 down vote accepted

From the screenshot I'd say that looks like the model is missing or corrupt.

First thing to do in this case is verify your TF2 file cache, this will check your TF2 install is up to date and no files are corrupt or missing - and download anything it needs to make your game correct.

Go to the game's properties from the Steam Library and you'll find a "Verify Integrity of Game Cache..." button, hit that and let it check for anything broken and re-download it (this may take some time depending on how much has to be redownloaded). You might need to re-start Steam before trying again.

share|improve this answer

Or reinstall Team Fortress 2 that had an update in this year because the game has new Steam Workshop hats. Even guns and melee weapons too. That is how you install the hats again. Re-install if the game is up to date if the Steam Workshop Hats, Weapons and Melee Weapons where never installed when they confirmed them.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.