Arqade is a question and answer site for passionate videogamers on all platforms. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a MacBook Pro 15", that I have connected another screen to.

It;s running perfect with all programs, except when I want to game, because every time I try to open a game (eg HoN/WoW) it opens on my MacBook's built in monitor.

So I switch the game to windowed-mode and drag it over to my other screen, but when I then try to make it full screen, it returns to the built in monitor again.

What can I do to make games play in full screen on my external monitor?

share|improve this question

Using google i came upon this page: Full screen app mode doesn't play wel with external displays.

Now this is only with fullscreen apps but I think it might be the same problem. Reading a bit futher in the comments i found this :

Just go into System Preferences > Displays > Arrangement and move the white menu bar strip to the external monitor’s rectangle. Full screen apps seem to associated only with whatever is considered the primary display.

Ps: Don't have osx so I wouldn't know if this works...

share|improve this answer
works perfect for steam games. Thanks. – AlexWei Jul 22 '15 at 2:35
confirming that it worked on MacBook Air, thanks – Andrei Cristian Prodan Jun 28 at 13:03

I'm running OS 10.9.3 using a MacBook Pro 17" with retina display connected to a 27" Studio (Thunderbolt) Display. I mirrored the displays, then selected optimize for Thunderbolt Display. When I want to use both screens, I just deselect Mirror Displays, and it switches right over. It's the only decent way I've found to play games or watch movies/TV on my Studio Monitor, but it works fine!

share|improve this answer

You might be able to do it using F7 or FN+F7:

I believe that the standard F7 key is to change display modes when hooked up to an external monitor or projector.

It should look like this with a helpful ambiguous icon:

F7 key

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.